core-vm.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-netwatcher qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-vm
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: ntpdate
  123. Requires: net-tools
  124. Requires: nautilus-python
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. Requires: sed
  129. # for dispvm-prerun.sh
  130. Requires: procps-ng
  131. Requires: util-linux
  132. # for qubes-desktop-run
  133. Requires: pygobject3-base
  134. Requires: dbus-python
  135. # for qubes-session-autostart, xdg-icon
  136. Requires: pyxdg
  137. Requires: ImageMagick
  138. Requires: librsvg2-tools
  139. Requires: fakeroot
  140. Requires: desktop-notification-daemon
  141. # to show/hide nm-applet
  142. Requires: dconf
  143. Requires: pygtk2
  144. Requires: zenity
  145. Requires: qubes-libvchan
  146. Requires: qubes-db-vm
  147. %if 0%{fedora} >= 23
  148. Requires: python3-dnf-plugins-qubes-hooks
  149. %else
  150. Requires: python2-dnf-plugins-qubes-hooks
  151. %endif
  152. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  153. Obsoletes: qubes-upgrade-vm < 3.2
  154. BuildRequires: xen-devel
  155. BuildRequires: libX11-devel
  156. BuildRequires: qubes-utils-devel >= 3.1.3
  157. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  158. %package -n python2-dnf-plugins-qubes-hooks
  159. Summary: DNF plugin for Qubes specific post-installation actions
  160. BuildRequires: python2-devel
  161. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  162. %description -n python2-dnf-plugins-qubes-hooks
  163. DNF plugin for Qubes specific post-installation actions:
  164. * notify dom0 that updates were installed
  165. * refresh applications shortcut list
  166. %package -n python3-dnf-plugins-qubes-hooks
  167. Summary: DNF plugin for Qubes specific post-installation actions
  168. BuildRequires: python3-devel
  169. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  170. %description -n python3-dnf-plugins-qubes-hooks
  171. DNF plugin for Qubes specific post-installation actions:
  172. * notify dom0 that updates were installed
  173. * refresh applications shortcut list
  174. %define _builddir %(pwd)
  175. %define kde_service_dir /usr/share/kde4/services
  176. %description
  177. The Qubes core files for installation inside a Qubes VM.
  178. %prep
  179. # we operate on the current directory, so no need to unpack anything
  180. # symlink is to generate useful debuginfo packages
  181. rm -f %{name}-%{version}
  182. ln -sf . %{name}-%{version}
  183. %setup -T -D
  184. %build
  185. for dir in qubes-rpc qrexec misc; do
  186. (cd $dir; make)
  187. done
  188. %pre
  189. # Make sure there is a qubes group
  190. groupadd --force --system --gid 98 qubes
  191. id -u 'user' >/dev/null 2>&1 || {
  192. useradd --user-group --create-home --shell /bin/bash user
  193. }
  194. usermod -a --groups qubes user
  195. if [ "$1" != 1 ] ; then
  196. # do this whole %%pre thing only when updating for the first time...
  197. exit 0
  198. fi
  199. mkdir -p /var/lib/qubes
  200. if [ -e /etc/fstab ] ; then
  201. mv /etc/fstab /var/lib/qubes/fstab.orig
  202. fi
  203. usermod -p '' root
  204. usermod -L user
  205. %install
  206. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  207. make install-vm DESTDIR=$RPM_BUILD_ROOT
  208. %if %{fedora} >= 22
  209. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  210. %endif
  211. %triggerin -- initscripts
  212. if [ -e /etc/init/serial.conf ]; then
  213. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  214. fi
  215. %post
  216. # disable some Upstart services
  217. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  218. if [ -e /etc/init/$F.conf ]; then
  219. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  220. fi
  221. done
  222. # Create NetworkManager configuration if we do not have it
  223. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  224. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  225. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  226. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  227. fi
  228. /usr/lib/qubes/qubes-fix-nm-conf.sh
  229. # Remove ip_forward setting from sysctl, so NM will not reset it
  230. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  231. # Remove old firmware updates link
  232. if [ -L /lib/firmware/updates ]; then
  233. rm -f /lib/firmware/updates
  234. fi
  235. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  236. echo >> /etc/yum.conf
  237. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  238. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  239. fi
  240. # And actually setup the proxy usage in package managers
  241. /usr/lib/qubes/update-proxy-configs
  242. # Location of files which contains list of protected files
  243. mkdir -p /etc/qubes/protected-files.d
  244. . /usr/lib/qubes/init/functions
  245. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  246. if ! is_protected_file /etc/hosts ; then
  247. if ! grep -q localhost /etc/hosts; then
  248. cat <<EOF > /etc/hosts
  249. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  250. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  251. EOF
  252. fi
  253. fi
  254. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  255. # in the form expected by qubes-sysinit.sh
  256. if ! is_protected_file /etc/hostname ; then
  257. for ip in '127\.0\.0\.1' '::1'; do
  258. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  259. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  260. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  261. else
  262. echo "${ip} `hostname`" >> /etc/hosts
  263. fi
  264. done
  265. fi
  266. %if %{fedora} >= 20
  267. # Make sure there is a default locale set so gnome-terminal will start
  268. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  269. touch /etc/locale.conf
  270. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  271. fi
  272. # ... and make sure it is really generated
  273. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  274. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  275. base=`echo "$current_locale" | cut -f 1 -d .`
  276. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  277. [ -n "$charmap" ] && charmap="-f $charmap"
  278. localedef -i $base $charmap $current_locale
  279. fi
  280. %endif
  281. if [ "$1" != 1 ] ; then
  282. # do the rest of %%post thing only when updating for the first time...
  283. exit 0
  284. fi
  285. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  286. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  287. fi
  288. # Remove most of the udev scripts to speed up the VM boot time
  289. # Just leave the xen* scripts, that are needed if this VM was
  290. # ever used as a net backend (e.g. as a VPN domain in the future)
  291. #echo "--> Removing unnecessary udev scripts..."
  292. mkdir -p /var/lib/qubes/removed-udev-scripts
  293. for f in /etc/udev/rules.d/*
  294. do
  295. if [ $(basename $f) == "xen-backend.rules" ] ; then
  296. continue
  297. fi
  298. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  299. continue
  300. fi
  301. if echo $f | grep -q qubes; then
  302. continue
  303. fi
  304. mv $f /var/lib/qubes/removed-udev-scripts/
  305. done
  306. mkdir -p /rw
  307. #rm -f /etc/mtab
  308. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  309. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  310. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  311. %triggerin -- notification-daemon
  312. # Enable autostart of notification-daemon when installed
  313. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  314. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  315. fi
  316. exit 0
  317. %triggerin -- selinux-policy
  318. #echo "--> Disabling SELinux..."
  319. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  320. mv /etc/selinux/config.processed /etc/selinux/config
  321. setenforce 0 2>/dev/null
  322. exit 0
  323. %preun
  324. if [ "$1" = 0 ] ; then
  325. # no more packages left
  326. if [ -e /var/lib/qubes/fstab.orig ] ; then
  327. mv /var/lib/qubes/fstab.orig /etc/fstab
  328. fi
  329. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  330. if [ -e /var/lib/qubes/serial.orig ] ; then
  331. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  332. fi
  333. fi
  334. %postun
  335. if [ $1 -eq 0 ] ; then
  336. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  337. if [ -L /lib/firmware/updates ]; then
  338. rm /lib/firmware/updates
  339. fi
  340. rm -rf /var/lib/qubes/xdg
  341. fi
  342. %posttrans
  343. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  344. %clean
  345. rm -rf $RPM_BUILD_ROOT
  346. rm -f %{name}-%{version}
  347. %files
  348. %defattr(-,root,root,-)
  349. %dir /var/lib/qubes
  350. %dir /var/run/qubes
  351. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  352. %{kde_service_dir}/qvm-copy.desktop
  353. %{kde_service_dir}/qvm-move.desktop
  354. %{kde_service_dir}/qvm-dvm.desktop
  355. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  356. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  357. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  358. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  359. /etc/fstab
  360. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  361. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  362. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  363. %dir /etc/qubes-rpc
  364. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  365. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  366. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  367. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  368. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  369. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  370. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  371. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  372. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  373. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  374. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  375. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  376. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  377. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  378. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  379. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  380. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  381. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  382. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  383. %dir /etc/qubes/autostart
  384. /etc/qubes/autostart/README.txt
  385. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  386. %dir /etc/qubes/suspend-pre.d
  387. /etc/qubes/suspend-pre.d/README
  388. %dir /etc/qubes/suspend-post.d
  389. /etc/qubes/suspend-post.d/README
  390. %config(noreplace) /etc/sudoers.d/qubes
  391. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  392. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  393. %config(noreplace) /etc/qubes/iptables.rules
  394. %config(noreplace) /etc/qubes/ip6tables.rules
  395. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  396. %config(noreplace) /etc/tinyproxy/updates-blacklist
  397. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  398. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  399. %config(noreplace) /etc/qubes-suspend-module-blacklist
  400. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  401. /etc/xen/scripts/vif-route-qubes
  402. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  403. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  404. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  405. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  406. %if %{fedora} < 22
  407. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  408. %endif
  409. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  410. /usr/sbin/qubes-serial-login
  411. /usr/bin/qvm-copy-to-vm
  412. /usr/bin/qvm-move-to-vm
  413. /usr/bin/qvm-open-in-dvm
  414. /usr/bin/qvm-open-in-vm
  415. /usr/bin/qvm-run
  416. /usr/bin/qvm-mru-entry
  417. /usr/bin/xenstore-watch-qubes
  418. /usr/bin/qubes-desktop-run
  419. /usr/bin/qubes-open
  420. /usr/bin/qrexec-fork-server
  421. /usr/bin/qrexec-client-vm
  422. /usr/bin/qubes-session-autostart
  423. %dir /usr/lib/qubes
  424. /usr/lib/qubes/vusb-ctl.py*
  425. /usr/lib/qubes/dispvm-prerun.sh
  426. /usr/lib/qubes/sync-ntp-clock
  427. /usr/lib/qubes/prepare-suspend
  428. /usr/lib/qubes/network-manager-prepare-conf-dir
  429. /usr/lib/qubes/show-hide-nm-applet.sh
  430. /usr/lib/qubes/qrexec-agent
  431. /usr/lib/qubes/qrexec-client-vm
  432. /usr/lib/qubes/qrexec_client_vm
  433. /usr/lib/qubes/qubes-rpc-multiplexer
  434. /usr/lib/qubes/qfile-agent
  435. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  436. /usr/lib/qubes/qopen-in-vm
  437. /usr/lib/qubes/qrun-in-vm
  438. /usr/lib/qubes/qubes-download-dom0-updates.sh
  439. /usr/lib/qubes/qubes-fix-nm-conf.sh
  440. /usr/lib/qubes/qubes-setup-dnat-to-ns
  441. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  442. /usr/lib/qubes/qvm-copy-to-vm.gnome
  443. /usr/lib/qubes/qvm-copy-to-vm.kde
  444. /usr/lib/qubes/qvm-move-to-vm.gnome
  445. /usr/lib/qubes/qvm-move-to-vm.kde
  446. /usr/lib/qubes/setup-ip
  447. /usr/lib/qubes/tar2qfile
  448. /usr/lib/qubes/vm-file-editor
  449. /usr/lib/qubes/iptables-updates-proxy
  450. /usr/lib/qubes/close-window
  451. /usr/lib/qubes/xdg-icon
  452. /usr/lib/qubes/update-proxy-configs
  453. /usr/lib/qubes/upgrades-installed-check
  454. /usr/lib/qubes/upgrades-status-notify
  455. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  456. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  457. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  458. %dir /usr/lib/qubes/init
  459. /usr/lib/qubes/init/*.sh
  460. /usr/lib/qubes/init/functions
  461. %dir /usr/lib/qubes-bind-dirs.d
  462. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  463. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  464. /usr/sbin/qubes-firewall
  465. /usr/sbin/qubes-netwatcher
  466. /usr/share/qubes/serial.conf
  467. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  468. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  469. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  470. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  471. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  472. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  473. /usr/share/qubes/mime-override/globs
  474. /usr/share/qubes/qubes-master-key.asc
  475. %dir /home_volatile
  476. %attr(700,user,user) /home_volatile/user
  477. %dir /mnt/removable
  478. %dir /rw
  479. %files -n python2-dnf-plugins-qubes-hooks
  480. %{python2_sitelib}/dnf-plugins/*
  481. %files -n python3-dnf-plugins-qubes-hooks
  482. %{python3_sitelib}/dnf-plugins/*
  483. %package sysvinit
  484. Summary: Qubes unit files for SysV init style or upstart
  485. License: GPL v2 only
  486. Group: Qubes
  487. Requires: upstart
  488. Requires: qubes-core-vm
  489. Provides: qubes-core-vm-init-scripts
  490. Conflicts: qubes-core-vm-systemd
  491. %description sysvinit
  492. The Qubes core startup configuration for SysV init (or upstart).
  493. %files sysvinit
  494. /etc/init.d/qubes-sysinit
  495. /etc/init.d/qubes-core-early
  496. /etc/init.d/qubes-core
  497. /etc/init.d/qubes-dvm
  498. /etc/init.d/qubes-core-netvm
  499. /etc/init.d/qubes-firewall
  500. /etc/init.d/qubes-netwatcher
  501. /etc/init.d/qubes-iptables
  502. /etc/init.d/qubes-updates-proxy
  503. /etc/init.d/qubes-qrexec-agent
  504. /etc/sysconfig/modules/qubes-core.modules
  505. /etc/sysconfig/modules/qubes-misc.modules
  506. %post sysvinit
  507. #echo "--> Turning off unnecessary services..."
  508. # FIXME: perhaps there is more elegant way to do this?
  509. for f in /etc/init.d/*
  510. do
  511. srv=`basename $f`
  512. [ $srv = 'functions' ] && continue
  513. [ $srv = 'killall' ] && continue
  514. [ $srv = 'halt' ] && continue
  515. [ $srv = 'single' ] && continue
  516. [ $srv = 'reboot' ] && continue
  517. [ $srv = 'qubes-gui' ] && continue
  518. chkconfig $srv off
  519. done
  520. #echo "--> Enabling essential services..."
  521. chkconfig rsyslog on
  522. chkconfig haldaemon on
  523. chkconfig messagebus on
  524. for svc in %qubes_services ; do
  525. if [ "$1" = 1 ] ; then
  526. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  527. else
  528. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  529. fi
  530. done
  531. # TODO: make this not display the silly message about security context...
  532. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  533. %preun sysvinit
  534. if [ "$1" = 0 ] ; then
  535. # no more packages left
  536. for svc in %qubes_services ; do
  537. chkconfig --del $svc
  538. done
  539. fi
  540. %package systemd
  541. Summary: Qubes unit files for SystemD init style
  542. License: GPL v2 only
  543. Group: Qubes
  544. Requires: systemd
  545. Requires(post): systemd-units
  546. Requires(preun): systemd-units
  547. Requires(postun): systemd-units
  548. Requires: qubes-core-vm
  549. Provides: qubes-core-vm-init-scripts
  550. Conflicts: qubes-core-vm-sysvinit
  551. %description systemd
  552. The Qubes core startup configuration for SystemD init.
  553. %files systemd
  554. %defattr(-,root,root,-)
  555. /lib/systemd/system/qubes-dvm.service
  556. /lib/systemd/system/qubes-misc-post.service
  557. /lib/systemd/system/qubes-firewall.service
  558. /lib/systemd/system/qubes-mount-dirs.service
  559. /lib/systemd/system/qubes-netwatcher.service
  560. /lib/systemd/system/qubes-network.service
  561. /lib/systemd/system/qubes-iptables.service
  562. /lib/systemd/system/qubes-sysinit.service
  563. /lib/systemd/system/qubes-early-vm-config.service
  564. /lib/systemd/system/qubes-update-check.service
  565. /lib/systemd/system/qubes-update-check.timer
  566. /lib/systemd/system/qubes-updates-proxy.service
  567. /lib/systemd/system/qubes-qrexec-agent.service
  568. /lib/systemd/system-preset/%qubes_preset_file
  569. /lib/modules-load.d/qubes-core.conf
  570. /lib/modules-load.d/qubes-misc.conf
  571. /usr/lib/qubes/init/qubes-iptables
  572. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  573. /lib/systemd/system/crond.service.d/30_qubes.conf
  574. /lib/systemd/system/cups.service.d/30_qubes.conf
  575. /lib/systemd/system/cups.socket.d/30_qubes.conf
  576. /lib/systemd/system/cups.path.d/30_qubes.conf
  577. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  578. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  579. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  580. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  581. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  582. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  583. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  584. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  585. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  586. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  587. /lib/systemd/system/tor.service.d/30_qubes.conf
  588. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  589. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  590. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  591. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  592. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  593. %post systemd
  594. changed=
  595. %scriptletfuns
  596. if [ $1 -eq 1 ]
  597. then
  598. preset_units %{_presetdir}/%qubes_preset_file initial
  599. changed=true
  600. else
  601. preset_units %{_presetdir}/%qubes_preset_file upgrade
  602. changed=true
  603. # Upgrade path - now qubes-iptables is used instead
  604. for svc in iptables ip6tables
  605. do
  606. if [ -f "$svc".service ]
  607. then
  608. systemctl --no-reload preset "$svc".service
  609. changed=true
  610. fi
  611. done
  612. fi
  613. if [ $1 -eq 1 ]
  614. then
  615. # First install.
  616. # Set default "runlevel".
  617. # FIXME: this ought to be done via kernel command line.
  618. # The fewer deviations of the template from the seed
  619. # image, the better.
  620. rm -f %{_sysconfdir}/systemd/system/default.target
  621. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  622. changed=true
  623. fi
  624. # remove old symlinks
  625. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  626. then
  627. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  628. changed=true
  629. fi
  630. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  631. then
  632. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  633. changed=true
  634. fi
  635. if [ "x$changed" != "x" ]
  636. then
  637. systemctl daemon-reload
  638. fi
  639. %preun systemd
  640. if [ $1 -eq 0 ] ; then
  641. # Run this only during uninstall.
  642. # Save the preset file to later use it to re-preset services there
  643. # once the Qubes OS preset file is removed.
  644. mkdir -p %{_rundir}/qubes-uninstall
  645. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  646. fi
  647. %postun systemd
  648. changed=
  649. %scriptletfuns
  650. if [ -d %{_rundir}/qubes-uninstall ]
  651. then
  652. # We have a saved preset file (or more).
  653. # Re-preset the units mentioned there.
  654. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  655. rm -rf %{_rundir}/qubes-uninstall
  656. changed=true
  657. fi
  658. if [ "x$changed" != "x" ]
  659. then
  660. systemctl daemon-reload
  661. fi