core-agent.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: ntpdate
  120. Requires: qubes-utils >= 3.1.3
  121. Requires: initscripts
  122. Requires: gawk
  123. Requires: sed
  124. Requires: util-linux
  125. # for qubes-desktop-run
  126. Requires: pygobject3-base
  127. Requires: dbus-python
  128. # for qubes-session-autostart, xdg-icon
  129. Requires: pyxdg
  130. Requires: python-daemon
  131. # for qvm-feature-request
  132. Requires: python2-qubesdb
  133. Requires: ImageMagick
  134. Requires: librsvg2-tools
  135. Requires: desktop-notification-daemon
  136. Requires: zenity
  137. Requires: qubes-libvchan
  138. Requires: qubes-db-vm
  139. %if 0%{fedora} >= 23
  140. Requires: python3-dnf-plugins-qubes-hooks
  141. %else
  142. Requires: python2-dnf-plugins-qubes-hooks
  143. %endif
  144. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  145. Obsoletes: qubes-upgrade-vm < 3.2
  146. Provides: qubes-core-vm = %{version}-%{release}
  147. Obsoletes: qubes-core-vm < 4.0.0
  148. Provides: qubes-core-vm-doc = %{version}-%{release}
  149. Obsoletes: qubes-core-vm-doc < 4.0.0
  150. BuildRequires: pandoc
  151. BuildRequires: xen-devel
  152. BuildRequires: libX11-devel
  153. BuildRequires: qubes-utils-devel >= 3.1.3
  154. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  155. %description
  156. The Qubes core files for installation inside a Qubes VM.
  157. %package -n python2-dnf-plugins-qubes-hooks
  158. Summary: DNF plugin for Qubes specific post-installation actions
  159. BuildRequires: python2-devel
  160. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  161. %description -n python2-dnf-plugins-qubes-hooks
  162. DNF plugin for Qubes specific post-installation actions:
  163. * notify dom0 that updates were installed
  164. * refresh applications shortcut list
  165. %package -n python3-dnf-plugins-qubes-hooks
  166. Summary: DNF plugin for Qubes specific post-installation actions
  167. BuildRequires: python3-devel
  168. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  169. %description -n python3-dnf-plugins-qubes-hooks
  170. DNF plugin for Qubes specific post-installation actions:
  171. * notify dom0 that updates were installed
  172. * refresh applications shortcut list
  173. %package nautilus
  174. Summary: Qubes integration for Nautilus
  175. Requires: qubes-core-agent
  176. Requires: nautilus-python
  177. Conflicts: qubes-core-vm < 4.0.0
  178. %description nautilus
  179. Nautilus addons for inter-VM file copy/move/open.
  180. %package dom0-updates
  181. Summary: Scripts required to handle dom0 updates
  182. Requires: qubes-core-agent
  183. Requires: fakeroot
  184. Conflicts: qubes-core-vm < 4.0.0
  185. %description dom0-updates
  186. Scripts required to handle dom0 updates.
  187. %package networking
  188. Summary: Networking support for Qubes VM
  189. Requires: ethtool
  190. Requires: net-tools
  191. Requires: nftables
  192. Requires: nmap-ncat
  193. Requires: qubes-core-agent
  194. Requires: tinyproxy
  195. Conflicts: qubes-core-vm < 4.0.0
  196. %description networking
  197. This package provides:
  198. * basic network functionality (setting IP address, DNS, default gateway)
  199. * proxy service used by TemplateVMs to download updates
  200. * qubes-firewall service (FirewallVM)
  201. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  202. qubes-core-agent-network-manager.
  203. %package network-manager
  204. Summary: NetworkManager integration for Qubes VM
  205. # to show/hide nm-applet
  206. Requires: NetworkManager >= 0.8.1-1
  207. Requires: dconf
  208. Requires: qubes-core-agent-networking
  209. Conflicts: qubes-core-vm < 4.0.0
  210. %description network-manager
  211. Integration of NetworkManager for Qubes VM:
  212. * make connections config persistent
  213. * adjust DNS redirections when needed
  214. * show/hide NetworkManager applet icon
  215. %define _builddir %(pwd)
  216. %define kde_service_dir /usr/share/kde4/services
  217. %prep
  218. # we operate on the current directory, so no need to unpack anything
  219. # symlink is to generate useful debuginfo packages
  220. rm -f %{name}-%{version}
  221. ln -sf . %{name}-%{version}
  222. %setup -T -D
  223. %build
  224. for dir in qubes-rpc qrexec misc; do
  225. (cd $dir; make)
  226. done
  227. make -C doc manpages
  228. %pre
  229. # Make sure there is a qubes group
  230. groupadd --force --system --gid 98 qubes
  231. id -u 'user' >/dev/null 2>&1 || {
  232. useradd --user-group --create-home --shell /bin/bash user
  233. }
  234. usermod -a --groups qubes user
  235. if [ "$1" != 1 ] ; then
  236. # do this whole %%pre thing only when updating for the first time...
  237. exit 0
  238. fi
  239. mkdir -p /var/lib/qubes
  240. if [ -e /etc/fstab ] ; then
  241. mv /etc/fstab /var/lib/qubes/fstab.orig
  242. fi
  243. usermod -p '' root
  244. usermod -L user
  245. %install
  246. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  247. make install-vm DESTDIR=$RPM_BUILD_ROOT
  248. make -C doc install DESTDIR=$RPM_BUILD_ROOT
  249. %if %{fedora} >= 22
  250. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  251. %endif
  252. %triggerin -- initscripts
  253. if [ -e /etc/init/serial.conf ]; then
  254. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  255. fi
  256. %post
  257. # disable some Upstart services
  258. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  259. if [ -e /etc/init/$F.conf ]; then
  260. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  261. fi
  262. done
  263. # Remove old firmware updates link
  264. if [ -L /lib/firmware/updates ]; then
  265. rm -f /lib/firmware/updates
  266. fi
  267. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  268. echo >> /etc/yum.conf
  269. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  270. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  271. fi
  272. # And actually setup the proxy usage in package managers
  273. /usr/lib/qubes/update-proxy-configs
  274. # Location of files which contains list of protected files
  275. mkdir -p /etc/qubes/protected-files.d
  276. . /usr/lib/qubes/init/functions
  277. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  278. if ! is_protected_file /etc/hosts ; then
  279. if ! grep -q localhost /etc/hosts; then
  280. cat <<EOF > /etc/hosts
  281. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  282. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  283. EOF
  284. fi
  285. fi
  286. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  287. # in the form expected by qubes-sysinit.sh
  288. if ! is_protected_file /etc/hostname ; then
  289. for ip in '127\.0\.0\.1' '::1'; do
  290. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  291. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  292. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  293. else
  294. echo "${ip} `hostname`" >> /etc/hosts
  295. fi
  296. done
  297. fi
  298. %if %{fedora} >= 20
  299. # Make sure there is a default locale set so gnome-terminal will start
  300. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  301. touch /etc/locale.conf
  302. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  303. fi
  304. # ... and make sure it is really generated
  305. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  306. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  307. base=`echo "$current_locale" | cut -f 1 -d .`
  308. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  309. [ -n "$charmap" ] && charmap="-f $charmap"
  310. localedef -i $base $charmap $current_locale
  311. fi
  312. %endif
  313. if [ "$1" != 1 ] ; then
  314. # do the rest of %%post thing only when updating for the first time...
  315. exit 0
  316. fi
  317. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  318. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  319. fi
  320. # Remove most of the udev scripts to speed up the VM boot time
  321. # Just leave the xen* scripts, that are needed if this VM was
  322. # ever used as a net backend (e.g. as a VPN domain in the future)
  323. #echo "--> Removing unnecessary udev scripts..."
  324. mkdir -p /var/lib/qubes/removed-udev-scripts
  325. for f in /etc/udev/rules.d/*
  326. do
  327. if [ $(basename $f) == "xen-backend.rules" ] ; then
  328. continue
  329. fi
  330. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  331. continue
  332. fi
  333. if echo $f | grep -q qubes; then
  334. continue
  335. fi
  336. mv $f /var/lib/qubes/removed-udev-scripts/
  337. done
  338. mkdir -p /rw
  339. #rm -f /etc/mtab
  340. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  341. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  342. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  343. %triggerin -- notification-daemon
  344. # Enable autostart of notification-daemon when installed
  345. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  346. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  347. fi
  348. exit 0
  349. %triggerin -- selinux-policy
  350. #echo "--> Disabling SELinux..."
  351. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  352. mv /etc/selinux/config.processed /etc/selinux/config
  353. setenforce 0 2>/dev/null
  354. exit 0
  355. %post network-manager
  356. # Create NetworkManager configuration if we do not have it
  357. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  358. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  359. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  360. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  361. fi
  362. # Remove ip_forward setting from sysctl, so NM will not reset it
  363. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  364. /usr/lib/qubes/qubes-fix-nm-conf.sh
  365. %preun
  366. if [ "$1" = 0 ] ; then
  367. # no more packages left
  368. if [ -e /var/lib/qubes/fstab.orig ] ; then
  369. mv /var/lib/qubes/fstab.orig /etc/fstab
  370. fi
  371. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  372. if [ -e /var/lib/qubes/serial.orig ] ; then
  373. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  374. fi
  375. fi
  376. %postun
  377. if [ $1 -eq 0 ] ; then
  378. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  379. if [ -L /lib/firmware/updates ]; then
  380. rm /lib/firmware/updates
  381. fi
  382. rm -rf /var/lib/qubes/xdg
  383. fi
  384. %posttrans
  385. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  386. %clean
  387. rm -rf $RPM_BUILD_ROOT
  388. rm -f %{name}-%{version}
  389. %files
  390. %defattr(-,root,root,-)
  391. %dir /var/lib/qubes
  392. %dir /var/run/qubes
  393. %{kde_service_dir}/qvm-copy.desktop
  394. %{kde_service_dir}/qvm-move.desktop
  395. %{kde_service_dir}/qvm-dvm.desktop
  396. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  397. /etc/fstab
  398. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  399. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  400. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  401. %dir /etc/qubes-rpc
  402. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  403. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  404. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  405. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  406. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  407. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  408. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  409. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  410. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  411. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  412. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  413. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  414. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  415. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  416. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  417. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  418. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  419. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  420. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  421. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  422. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  423. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  424. %dir /etc/qubes/autostart
  425. /etc/qubes/autostart/README.txt
  426. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  427. %dir /etc/qubes/suspend-pre.d
  428. /etc/qubes/suspend-pre.d/README
  429. %dir /etc/qubes/suspend-post.d
  430. /etc/qubes/suspend-post.d/README
  431. %dir /etc/qubes/post-install.d
  432. /etc/qubes/post-install.d/README
  433. /etc/qubes/post-install.d/*.sh
  434. %config(noreplace) /etc/sudoers.d/qubes
  435. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  436. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  437. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  438. %config(noreplace) /etc/qubes-suspend-module-blacklist
  439. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  440. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  441. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  442. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  443. %if %{fedora} < 22
  444. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  445. %endif
  446. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  447. /usr/sbin/qubes-serial-login
  448. /usr/bin/qvm-copy-to-vm
  449. /usr/bin/qvm-move-to-vm
  450. /usr/bin/qvm-open-in-dvm
  451. /usr/bin/qvm-open-in-vm
  452. /usr/bin/qvm-run-vm
  453. /usr/bin/qvm-features-request
  454. /usr/bin/xenstore-watch-qubes
  455. /usr/bin/qubes-desktop-run
  456. /usr/bin/qubes-open
  457. /usr/bin/qrexec-fork-server
  458. /usr/bin/qrexec-client-vm
  459. /usr/bin/qubes-session-autostart
  460. %dir /usr/lib/qubes
  461. /usr/lib/qubes/vusb-ctl.py*
  462. /usr/lib/qubes/sync-ntp-clock
  463. /usr/lib/qubes/prepare-suspend
  464. /usr/lib/qubes/qrexec-agent
  465. /usr/lib/qubes/qrexec-client-vm
  466. /usr/lib/qubes/qrexec_client_vm
  467. /usr/lib/qubes/qubes-rpc-multiplexer
  468. /usr/lib/qubes/qfile-agent
  469. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  470. /usr/lib/qubes/qopen-in-vm
  471. /usr/lib/qubes/qrun-in-vm
  472. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  473. /usr/lib/qubes/qvm-copy-to-vm.kde
  474. /usr/lib/qubes/qvm-move-to-vm.kde
  475. /usr/lib/qubes/tar2qfile
  476. /usr/lib/qubes/vm-file-editor
  477. /usr/lib/qubes/close-window
  478. /usr/lib/qubes/xdg-icon
  479. /usr/lib/qubes/update-proxy-configs
  480. /usr/lib/qubes/upgrades-installed-check
  481. /usr/lib/qubes/upgrades-status-notify
  482. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  483. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  484. %dir /usr/lib/qubes/init
  485. /usr/lib/qubes/init/bind-dirs.sh
  486. /usr/lib/qubes/init/control-printer-icon.sh
  487. /usr/lib/qubes/init/functions
  488. /usr/lib/qubes/init/misc-post-stop.sh
  489. /usr/lib/qubes/init/misc-post.sh
  490. /usr/lib/qubes/init/mount-dirs.sh
  491. /usr/lib/qubes/init/qubes-early-vm-config.sh
  492. /usr/lib/qubes/init/qubes-random-seed.sh
  493. /usr/lib/qubes/init/qubes-sysinit.sh
  494. /usr/lib/qubes/init/setup-rw.sh
  495. /usr/lib/qubes/init/setup-rwdev.sh
  496. /usr/lib/qubes/init/functions
  497. %dir /usr/lib/qubes-bind-dirs.d
  498. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  499. /usr/lib/python2.7/site-packages/qubesxdg.py*
  500. /usr/share/qubes/serial.conf
  501. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  502. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  503. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  504. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  505. %{_mandir}/man1/qvm-*.1*
  506. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  507. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  508. %dir %{python_sitelib}/qubesagent
  509. %{python_sitelib}/qubesagent/__init__.py*
  510. %{python_sitelib}/qubesagent/firewall.py*
  511. %{python_sitelib}/qubesagent/test_firewall.py*
  512. /usr/share/qubes/mime-override/globs
  513. /usr/share/qubes/qubes-master-key.asc
  514. %dir /mnt/removable
  515. %dir /rw
  516. %files -n python2-dnf-plugins-qubes-hooks
  517. %{python2_sitelib}/dnf-plugins/*
  518. %files -n python3-dnf-plugins-qubes-hooks
  519. %{python3_sitelib}/dnf-plugins/*
  520. %files nautilus
  521. /usr/lib/qubes/qvm-copy-to-vm.gnome
  522. /usr/lib/qubes/qvm-move-to-vm.gnome
  523. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  524. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  525. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  526. %files dom0-updates
  527. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  528. /usr/lib/qubes/qubes-download-dom0-updates.sh
  529. %files networking
  530. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  531. %config(noreplace) /etc/qubes/ip6tables.rules
  532. %config(noreplace) /etc/qubes/iptables.rules
  533. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  534. %config(noreplace) /etc/tinyproxy/updates-blacklist
  535. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  536. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  537. /etc/xen/scripts/vif-qubes-nat.sh
  538. /etc/xen/scripts/vif-route-qubes
  539. /lib/systemd/system/qubes-firewall.service
  540. /lib/systemd/system/qubes-iptables.service
  541. /lib/systemd/system/qubes-network.service
  542. /lib/systemd/system/qubes-updates-proxy.service
  543. /usr/lib/qubes/init/network-proxy-setup.sh
  544. /usr/lib/qubes/init/qubes-iptables
  545. /usr/lib/qubes/iptables-updates-proxy
  546. /usr/lib/qubes/qubes-setup-dnat-to-ns
  547. /usr/lib/qubes/setup-ip
  548. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  549. /usr/sbin/qubes-firewall
  550. %files network-manager
  551. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  552. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  553. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  554. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  555. /usr/lib/qubes/network-manager-prepare-conf-dir
  556. /usr/lib/qubes/qubes-fix-nm-conf.sh
  557. /usr/lib/qubes/show-hide-nm-applet.sh
  558. %package sysvinit
  559. Summary: Qubes unit files for SysV init style or upstart
  560. License: GPL v2 only
  561. Group: Qubes
  562. Requires: upstart
  563. Requires: qubes-core-agent
  564. Requires: qubes-core-agent-networking
  565. Provides: qubes-core-agent-init-scripts
  566. Conflicts: qubes-core-agent-systemd
  567. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  568. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  569. %description sysvinit
  570. The Qubes core startup configuration for SysV init (or upstart).
  571. %files sysvinit
  572. /etc/init.d/qubes-sysinit
  573. /etc/init.d/qubes-core-early
  574. /etc/init.d/qubes-core
  575. /etc/init.d/qubes-core-netvm
  576. /etc/init.d/qubes-firewall
  577. /etc/init.d/qubes-iptables
  578. /etc/init.d/qubes-updates-proxy
  579. /etc/init.d/qubes-qrexec-agent
  580. /etc/init.d/qubes-updates-proxy-forwarder
  581. /etc/sysconfig/modules/qubes-core.modules
  582. /etc/sysconfig/modules/qubes-misc.modules
  583. %post sysvinit
  584. #echo "--> Turning off unnecessary services..."
  585. # FIXME: perhaps there is more elegant way to do this?
  586. for f in /etc/init.d/*
  587. do
  588. srv=`basename $f`
  589. [ $srv = 'functions' ] && continue
  590. [ $srv = 'killall' ] && continue
  591. [ $srv = 'halt' ] && continue
  592. [ $srv = 'single' ] && continue
  593. [ $srv = 'reboot' ] && continue
  594. [ $srv = 'qubes-gui' ] && continue
  595. chkconfig $srv off
  596. done
  597. #echo "--> Enabling essential services..."
  598. chkconfig rsyslog on
  599. chkconfig haldaemon on
  600. chkconfig messagebus on
  601. for svc in %qubes_services ; do
  602. if [ "$1" = 1 ] ; then
  603. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  604. else
  605. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  606. fi
  607. done
  608. # dropped services
  609. chkconfig qubes-netwatcher off || :
  610. # TODO: make this not display the silly message about security context...
  611. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  612. %preun sysvinit
  613. if [ "$1" = 0 ] ; then
  614. # no more packages left
  615. for svc in %qubes_services ; do
  616. chkconfig --del $svc
  617. done
  618. fi
  619. %package systemd
  620. Summary: Qubes unit files for SystemD init style
  621. License: GPL v2 only
  622. Group: Qubes
  623. Requires: systemd
  624. Requires(post): systemd-units
  625. Requires(preun): systemd-units
  626. Requires(postun): systemd-units
  627. Requires: qubes-core-agent
  628. Provides: qubes-core-agent-init-scripts
  629. Conflicts: qubes-core-agent-sysvinit
  630. Provides: qubes-core-vm-systemd = %{version}-%{release}
  631. Obsoletes: qubes-core-vm-systemd < 4.0.0
  632. %description systemd
  633. The Qubes core startup configuration for SystemD init.
  634. %files systemd
  635. %defattr(-,root,root,-)
  636. /lib/systemd/system/qubes-misc-post.service
  637. /lib/systemd/system/qubes-mount-dirs.service
  638. /lib/systemd/system/qubes-sysinit.service
  639. /lib/systemd/system/qubes-early-vm-config.service
  640. /lib/systemd/system/qubes-update-check.service
  641. /lib/systemd/system/qubes-update-check.timer
  642. /lib/systemd/system/qubes-qrexec-agent.service
  643. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  644. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  645. /lib/systemd/system-preset/%qubes_preset_file
  646. /lib/modules-load.d/qubes-core.conf
  647. /lib/modules-load.d/qubes-misc.conf
  648. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  649. /lib/systemd/system/crond.service.d/30_qubes.conf
  650. /lib/systemd/system/cups.service.d/30_qubes.conf
  651. /lib/systemd/system/cups.socket.d/30_qubes.conf
  652. /lib/systemd/system/cups.path.d/30_qubes.conf
  653. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  654. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  655. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  656. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  657. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  658. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  659. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  660. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  661. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  662. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  663. /lib/systemd/system/tor.service.d/30_qubes.conf
  664. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  665. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  666. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  667. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  668. %post systemd
  669. changed=
  670. %scriptletfuns
  671. if [ $1 -eq 1 ]
  672. then
  673. preset_units %{_presetdir}/%qubes_preset_file initial
  674. changed=true
  675. else
  676. preset_units %{_presetdir}/%qubes_preset_file upgrade
  677. changed=true
  678. # Upgrade path - now qubes-iptables is used instead
  679. for svc in iptables ip6tables
  680. do
  681. if [ -f "$svc".service ]
  682. then
  683. systemctl --no-reload preset "$svc".service
  684. changed=true
  685. fi
  686. done
  687. fi
  688. if [ $1 -eq 1 ]
  689. then
  690. # First install.
  691. # Set default "runlevel".
  692. # FIXME: this ought to be done via kernel command line.
  693. # The fewer deviations of the template from the seed
  694. # image, the better.
  695. rm -f %{_sysconfdir}/systemd/system/default.target
  696. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  697. changed=true
  698. fi
  699. # remove old symlinks
  700. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  701. then
  702. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  703. changed=true
  704. fi
  705. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  706. then
  707. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  708. changed=true
  709. fi
  710. if [ "x$changed" != "x" ]
  711. then
  712. systemctl daemon-reload
  713. fi
  714. %preun systemd
  715. if [ $1 -eq 0 ] ; then
  716. # Run this only during uninstall.
  717. # Save the preset file to later use it to re-preset services there
  718. # once the Qubes OS preset file is removed.
  719. mkdir -p %{_rundir}/qubes-uninstall
  720. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  721. fi
  722. %postun systemd
  723. changed=
  724. %scriptletfuns
  725. if [ -d %{_rundir}/qubes-uninstall ]
  726. then
  727. # We have a saved preset file (or more).
  728. # Re-preset the units mentioned there.
  729. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  730. rm -rf %{_rundir}/qubes-uninstall
  731. changed=true
  732. fi
  733. if [ "x$changed" != "x" ]
  734. then
  735. systemctl daemon-reload
  736. fi