rules 503 B

123456789101112131415161718192021222324252627
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Uncomment this to turn on verbose mode.
  4. #export DH_VERBOSE=1
  5. export DESTDIR=$(shell pwd)/debian/qubes-core-agent
  6. %:
  7. dh $@ --with systemd
  8. override_dh_auto_build:
  9. make all
  10. override_dh_auto_install:
  11. make install-common install-deb install-systemd
  12. make -C qrexec install
  13. override_dh_fixperms:
  14. dh_fixperms -a -Xqfile-unpacker
  15. override_dh_systemd_start:
  16. dh_systemd_start --no-restart-on-upgrade
  17. override_dh_auto_clean:
  18. dh_auto_clean
  19. rm -f deb/* rpm/*/*