12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758 |
- #!/bin/bash
- # postinst script for core-agent-linux
- #
- # see: dh_installdeb(1)
- set -e
- # The postinst script may be called in the following ways:
- # * <postinst> 'configure' <most-recently-configured-version>
- # * <old-postinst> 'abort-upgrade' <new version>
- # * <conflictor's-postinst> 'abort-remove' 'in-favour' <package>
- # <new-version>
- # * <postinst> 'abort-remove'
- # * <deconfigured's-postinst> 'abort-deconfigure' 'in-favour'
- # <failed-install-package> <version> 'removing'
- # <conflicting-package> <version>
- #
- # For details, see http://www.debian.org/doc/debian-policy/ or
- # https://www.debian.org/doc/debian-policy/ch-maintainerscripts.html or
- # the debian-policy package
- case "${1}" in
- configure)
- # There is no system-wide Thunar custom actions. There is only a default
- # file and a user file created from the default one. Qubes actions need
- # to be placed after all already defined actions and before </actions>
- # the end of file.
- if [ -f /etc/xdg/Thunar/uca.xml ] ; then
- cp -p /etc/xdg/Thunar/uca.xml /etc/xdg/Thunar/uca.xml.bak
- #shellcheck disable=SC2016
- sed -i '$e cat /usr/lib/qubes/uca_qubes.xml' /etc/xdg/Thunar/uca.xml
- fi
- if [ -f /home/user/.config/Thunar/uca.xml ] ; then
- cp -p /home/user/.config/Thunar/uca.xml /home/user/.config/Thunar/uca.xml.bak
- #shellcheck disable=SC2016
- sed -i '$e cat /usr/lib/qubes/uca_qubes.xml' /home/user/.config/Thunar/uca.xml
- fi
- ;;
- abort-upgrade|abort-remove|abort-deconfigure)
- exit 0
- ;;
- *)
- echo "postinst called with unknown argument \`${1}'" >&2
- exit 1
- ;;
- esac
- # dh_installdeb will replace this with shell code automatically
- # generated by other debhelper scripts.
- #DEBHELPER#
- exit 0
- # vim: set ts=4 sw=4 sts=4 et :
|