core-vm.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. %if %{fedora} < 22
  34. Requires: yum-plugin-post-transaction-actions
  35. %endif
  36. Requires: NetworkManager >= 0.8.1-1
  37. %if %{fedora} >= 18
  38. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  39. Conflicts: firewalld
  40. %endif
  41. Requires: xdg-utils
  42. Requires: ethtool
  43. Requires: tinyproxy
  44. Requires: ntpdate
  45. Requires: net-tools
  46. Requires: nautilus-python
  47. Requires: qubes-utils >= 3.1.3
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. Requires: dbus-python
  52. # for qubes-session-autostart, xdg-icon
  53. Requires: pyxdg
  54. Requires: python-daemon
  55. Requires: nftables
  56. %if %{fedora} >= 20
  57. # gpk-update-viewer required by qubes-manager
  58. Requires: gnome-packagekit-updater
  59. %endif
  60. Requires: ImageMagick
  61. Requires: librsvg2-tools
  62. Requires: fakeroot
  63. Requires: desktop-notification-daemon
  64. # to show/hide nm-applet
  65. Requires: dconf
  66. Requires: pygtk2
  67. Requires: zenity
  68. Requires: qubes-libvchan
  69. Requires: qubes-db-vm
  70. %if 0%{fedora} >= 23
  71. Requires: python3-dnf-plugins-qubes-hooks
  72. %else
  73. Requires: python2-dnf-plugins-qubes-hooks
  74. %endif
  75. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  76. Obsoletes: qubes-upgrade-vm < 3.2
  77. BuildRequires: xen-devel
  78. BuildRequires: libX11-devel
  79. BuildRequires: qubes-utils-devel >= 3.1.3
  80. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  81. %package -n python2-dnf-plugins-qubes-hooks
  82. Summary: DNF plugin for Qubes specific post-installation actions
  83. BuildRequires: python2-devel
  84. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  85. %description -n python2-dnf-plugins-qubes-hooks
  86. DNF plugin for Qubes specific post-installation actions:
  87. * notify dom0 that updates were installed
  88. * refresh applications shortcut list
  89. %package -n python3-dnf-plugins-qubes-hooks
  90. Summary: DNF plugin for Qubes specific post-installation actions
  91. BuildRequires: python3-devel
  92. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  93. %description -n python3-dnf-plugins-qubes-hooks
  94. DNF plugin for Qubes specific post-installation actions:
  95. * notify dom0 that updates were installed
  96. * refresh applications shortcut list
  97. %define _builddir %(pwd)
  98. %define kde_service_dir /usr/share/kde4/services
  99. %description
  100. The Qubes core files for installation inside a Qubes VM.
  101. %prep
  102. # we operate on the current directory, so no need to unpack anything
  103. # symlink is to generate useful debuginfo packages
  104. rm -f %{name}-%{version}
  105. ln -sf . %{name}-%{version}
  106. %setup -T -D
  107. %build
  108. for dir in qubes-rpc qrexec misc; do
  109. (cd $dir; make)
  110. done
  111. %pre
  112. # Make sure there is a qubes group
  113. groupadd --force --system --gid 98 qubes
  114. id -u 'user' >/dev/null 2>&1 || {
  115. useradd --user-group --create-home --shell /bin/bash user
  116. }
  117. usermod -a --groups qubes user
  118. if [ "$1" != 1 ] ; then
  119. # do this whole %%pre thing only when updating for the first time...
  120. exit 0
  121. fi
  122. mkdir -p /var/lib/qubes
  123. if [ -e /etc/fstab ] ; then
  124. mv /etc/fstab /var/lib/qubes/fstab.orig
  125. fi
  126. usermod -p '' root
  127. usermod -L user
  128. %install
  129. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  130. make install-vm DESTDIR=$RPM_BUILD_ROOT
  131. %if %{fedora} >= 22
  132. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  133. %endif
  134. %triggerin -- initscripts
  135. if [ -e /etc/init/serial.conf ]; then
  136. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  137. fi
  138. %post
  139. # disable some Upstart services
  140. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  141. if [ -e /etc/init/$F.conf ]; then
  142. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  143. fi
  144. done
  145. # Create NetworkManager configuration if we do not have it
  146. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  147. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  148. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  149. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  150. fi
  151. /usr/lib/qubes/qubes-fix-nm-conf.sh
  152. # Remove ip_forward setting from sysctl, so NM will not reset it
  153. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  154. # Remove old firmware updates link
  155. if [ -L /lib/firmware/updates ]; then
  156. rm -f /lib/firmware/updates
  157. fi
  158. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  159. echo >> /etc/yum.conf
  160. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  161. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  162. fi
  163. # And actually setup the proxy usage in package managers
  164. /usr/lib/qubes/update-proxy-configs
  165. # Location of files which contains list of protected files
  166. mkdir -p /etc/qubes/protected-files.d
  167. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  168. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  169. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  170. if ! grep -q localhost /etc/hosts; then
  171. cat <<EOF > /etc/hosts
  172. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  173. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  174. EOF
  175. fi
  176. fi
  177. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  178. # in the form expected by qubes-sysinit.sh
  179. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  180. for ip in '127\.0\.0\.1' '::1'; do
  181. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  182. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  183. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  184. else
  185. echo "${ip} `hostname`" >> /etc/hosts
  186. fi
  187. done
  188. fi
  189. %if %{fedora} >= 20
  190. # Make sure there is a default locale set so gnome-terminal will start
  191. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  192. touch /etc/locale.conf
  193. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  194. fi
  195. # ... and make sure it is really generated
  196. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  197. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  198. base=`echo "$current_locale" | cut -f 1 -d .`
  199. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  200. [ -n "$charmap" ] && charmap="-f $charmap"
  201. localedef -i $base $charmap $current_locale
  202. fi
  203. %endif
  204. if [ "$1" != 1 ] ; then
  205. # do the rest of %%post thing only when updating for the first time...
  206. exit 0
  207. fi
  208. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  209. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  210. fi
  211. # Remove most of the udev scripts to speed up the VM boot time
  212. # Just leave the xen* scripts, that are needed if this VM was
  213. # ever used as a net backend (e.g. as a VPN domain in the future)
  214. #echo "--> Removing unnecessary udev scripts..."
  215. mkdir -p /var/lib/qubes/removed-udev-scripts
  216. for f in /etc/udev/rules.d/*
  217. do
  218. if [ $(basename $f) == "xen-backend.rules" ] ; then
  219. continue
  220. fi
  221. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  222. continue
  223. fi
  224. if echo $f | grep -q qubes; then
  225. continue
  226. fi
  227. mv $f /var/lib/qubes/removed-udev-scripts/
  228. done
  229. mkdir -p /rw
  230. #rm -f /etc/mtab
  231. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  232. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  233. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  234. %triggerin -- notification-daemon
  235. # Enable autostart of notification-daemon when installed
  236. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  237. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  238. fi
  239. exit 0
  240. %triggerin -- selinux-policy
  241. #echo "--> Disabling SELinux..."
  242. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  243. mv /etc/selinux/config.processed /etc/selinux/config
  244. setenforce 0 2>/dev/null
  245. exit 0
  246. %preun
  247. if [ "$1" = 0 ] ; then
  248. # no more packages left
  249. if [ -e /var/lib/qubes/fstab.orig ] ; then
  250. mv /var/lib/qubes/fstab.orig /etc/fstab
  251. fi
  252. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  253. if [ -e /var/lib/qubes/serial.orig ] ; then
  254. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  255. fi
  256. fi
  257. %postun
  258. if [ $1 -eq 0 ] ; then
  259. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  260. if [ -L /lib/firmware/updates ]; then
  261. rm /lib/firmware/updates
  262. fi
  263. rm -rf /var/lib/qubes/xdg
  264. fi
  265. %posttrans
  266. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  267. %clean
  268. rm -rf $RPM_BUILD_ROOT
  269. rm -f %{name}-%{version}
  270. %files
  271. %defattr(-,root,root,-)
  272. %dir /var/lib/qubes
  273. %dir /var/run/qubes
  274. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  275. %{kde_service_dir}/qvm-copy.desktop
  276. %{kde_service_dir}/qvm-move.desktop
  277. %{kde_service_dir}/qvm-dvm.desktop
  278. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  279. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  280. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  281. /etc/dispvm-dotfiles.tbz
  282. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  283. /etc/fstab
  284. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  285. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  286. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  287. %dir /etc/qubes-rpc
  288. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  289. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  290. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  291. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  292. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  293. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  294. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  295. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  296. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  297. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  298. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  299. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  300. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  301. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  302. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  303. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  304. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  305. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  306. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  307. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  308. %dir /etc/qubes/autostart
  309. /etc/qubes/autostart/README.txt
  310. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  311. %dir /etc/qubes/suspend-pre.d
  312. /etc/qubes/suspend-pre.d/README
  313. %dir /etc/qubes/suspend-post.d
  314. /etc/qubes/suspend-post.d/README
  315. %config(noreplace) /etc/sudoers.d/qubes
  316. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  317. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  318. %config(noreplace) /etc/qubes/iptables.rules
  319. %config(noreplace) /etc/qubes/ip6tables.rules
  320. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  321. %config(noreplace) /etc/tinyproxy/updates-blacklist
  322. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  323. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  324. %config(noreplace) /etc/qubes-suspend-module-blacklist
  325. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  326. /etc/xen/scripts/vif-route-qubes
  327. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  328. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  329. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  330. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  331. %if %{fedora} < 22
  332. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  333. %endif
  334. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  335. /usr/sbin/qubes-serial-login
  336. /usr/bin/qvm-copy-to-vm
  337. /usr/bin/qvm-move-to-vm
  338. /usr/bin/qvm-open-in-dvm
  339. /usr/bin/qvm-open-in-vm
  340. /usr/bin/qvm-run
  341. /usr/bin/qvm-mru-entry
  342. /usr/bin/qvm-features-request
  343. /usr/bin/xenstore-watch-qubes
  344. /usr/bin/qubes-desktop-run
  345. /usr/bin/qubes-open
  346. /usr/bin/qrexec-fork-server
  347. /usr/bin/qrexec-client-vm
  348. /usr/bin/qubes-session-autostart
  349. %dir /usr/lib/qubes
  350. /usr/lib/qubes/vusb-ctl.py*
  351. /usr/lib/qubes/dispvm-prerun.sh
  352. /usr/lib/qubes/sync-ntp-clock
  353. /usr/lib/qubes/prepare-suspend
  354. /usr/lib/qubes/network-manager-prepare-conf-dir
  355. /usr/lib/qubes/show-hide-nm-applet.sh
  356. /usr/lib/qubes/qrexec-agent
  357. /usr/lib/qubes/qrexec-client-vm
  358. /usr/lib/qubes/qrexec_client_vm
  359. /usr/lib/qubes/qubes-rpc-multiplexer
  360. /usr/lib/qubes/qfile-agent
  361. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  362. /usr/lib/qubes/qopen-in-vm
  363. /usr/lib/qubes/qrun-in-vm
  364. /usr/lib/qubes/qubes-download-dom0-updates.sh
  365. /usr/lib/qubes/qubes-fix-nm-conf.sh
  366. /usr/lib/qubes/qubes-setup-dnat-to-ns
  367. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  368. /usr/lib/qubes/qvm-copy-to-vm.gnome
  369. /usr/lib/qubes/qvm-copy-to-vm.kde
  370. /usr/lib/qubes/qvm-move-to-vm.gnome
  371. /usr/lib/qubes/qvm-move-to-vm.kde
  372. /usr/lib/qubes/setup-ip
  373. /usr/lib/qubes/tar2qfile
  374. /usr/lib/qubes/vm-file-editor
  375. /usr/lib/qubes/iptables-updates-proxy
  376. /usr/lib/qubes/close-window
  377. /usr/lib/qubes/xdg-icon
  378. /usr/lib/qubes/update-proxy-configs
  379. /usr/lib/qubes/upgrades-installed-check
  380. /usr/lib/qubes/upgrades-status-notify
  381. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  382. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  383. /usr/lib/python2.7/site-packages/qubesxdg.py*
  384. /usr/sbin/qubes-firewall
  385. /usr/sbin/qubes-netwatcher
  386. /usr/share/qubes/serial.conf
  387. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  388. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  389. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  390. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  391. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  392. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  393. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  394. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  395. %dir %{python_sitelib}/qubesagent
  396. %{python_sitelib}/qubesagent/__init__.py*
  397. %{python_sitelib}/qubesagent/firewall.py*
  398. %{python_sitelib}/qubesagent/test_firewall.py*
  399. /usr/share/qubes/mime-override/globs
  400. /usr/share/qubes/qubes-master-key.asc
  401. %dir /home_volatile
  402. %attr(700,user,user) /home_volatile/user
  403. %dir /mnt/removable
  404. %dir /rw
  405. %files -n python2-dnf-plugins-qubes-hooks
  406. %{python2_sitelib}/dnf-plugins/*
  407. %files -n python3-dnf-plugins-qubes-hooks
  408. %{python3_sitelib}/dnf-plugins/*
  409. %package sysvinit
  410. Summary: Qubes unit files for SysV init style or upstart
  411. License: GPL v2 only
  412. Group: Qubes
  413. Requires: upstart
  414. Requires: qubes-core-vm
  415. Provides: qubes-core-vm-init-scripts
  416. Conflicts: qubes-core-vm-systemd
  417. %description sysvinit
  418. The Qubes core startup configuration for SysV init (or upstart).
  419. %files sysvinit
  420. /etc/init.d/qubes-core
  421. /etc/init.d/qubes-core-appvm
  422. /etc/init.d/qubes-core-netvm
  423. /etc/init.d/qubes-firewall
  424. /etc/init.d/qubes-netwatcher
  425. /etc/init.d/qubes-iptables
  426. /etc/init.d/qubes-updates-proxy
  427. /etc/init.d/qubes-qrexec-agent
  428. /etc/sysconfig/modules/qubes-core.modules
  429. /etc/sysconfig/modules/qubes-misc.modules
  430. %post sysvinit
  431. #echo "--> Turning off unnecessary services..."
  432. # FIXME: perhaps there is more elegant way to do this?
  433. for f in /etc/init.d/*
  434. do
  435. srv=`basename $f`
  436. [ $srv = 'functions' ] && continue
  437. [ $srv = 'killall' ] && continue
  438. [ $srv = 'halt' ] && continue
  439. [ $srv = 'single' ] && continue
  440. [ $srv = 'reboot' ] && continue
  441. [ $srv = 'qubes-gui' ] && continue
  442. chkconfig $srv off
  443. done
  444. #echo "--> Enabling essential services..."
  445. chkconfig rsyslog on
  446. chkconfig haldaemon on
  447. chkconfig messagebus on
  448. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  449. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  450. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  451. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  452. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  453. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  454. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  455. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  456. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  457. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  458. chkconfig --add qubes-iptables || echo "WARNING: Cannot add service qubes-iptables!"
  459. chkconfig qubes-iptables on || echo "WARNING: Cannot enable service qubes-iptables!"
  460. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  461. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  462. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  463. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  464. # TODO: make this not display the silly message about security context...
  465. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  466. %preun sysvinit
  467. if [ "$1" = 0 ] ; then
  468. # no more packages left
  469. chkconfig qubes-core off
  470. chkconfig qubes-core-netvm off
  471. chkconfig qubes-core-appvm off
  472. chkconfig qubes-firewall off
  473. chkconfig qubes-netwatcher off
  474. chkconfig qubes-updates-proxy off
  475. chkconfig qubes-qrexec-agent off
  476. fi
  477. %package systemd
  478. Summary: Qubes unit files for SystemD init style
  479. License: GPL v2 only
  480. Group: Qubes
  481. Requires: systemd
  482. Requires(post): systemd-units
  483. Requires(preun): systemd-units
  484. Requires(postun): systemd-units
  485. Requires: qubes-core-vm
  486. Provides: qubes-core-vm-init-scripts
  487. Conflicts: qubes-core-vm-sysvinit
  488. %description systemd
  489. The Qubes core startup configuration for SystemD init.
  490. %files systemd
  491. %defattr(-,root,root,-)
  492. /lib/systemd/system/qubes-dvm.service
  493. /lib/systemd/system/qubes-misc-post.service
  494. /lib/systemd/system/qubes-firewall.service
  495. /lib/systemd/system/qubes-mount-dirs.service
  496. /lib/systemd/system/qubes-netwatcher.service
  497. /lib/systemd/system/qubes-network.service
  498. /lib/systemd/system/qubes-iptables.service
  499. /lib/systemd/system/qubes-sysinit.service
  500. /lib/systemd/system/qubes-update-check.service
  501. /lib/systemd/system/qubes-update-check.timer
  502. /lib/systemd/system/qubes-updates-proxy.service
  503. /lib/systemd/system/qubes-qrexec-agent.service
  504. /lib/systemd/system-preset/75-qubes-vm.preset
  505. /lib/modules-load.d/qubes-core.conf
  506. /lib/modules-load.d/qubes-misc.conf
  507. %dir /usr/lib/qubes/init
  508. /usr/lib/qubes/init/prepare-dvm.sh
  509. /usr/lib/qubes/init/network-proxy-setup.sh
  510. /usr/lib/qubes/init/qubes-iptables
  511. /usr/lib/qubes/init/misc-post.sh
  512. /usr/lib/qubes/init/misc-post-stop.sh
  513. /usr/lib/qubes/init/mount-dirs.sh
  514. /usr/lib/qubes/init/qubes-random-seed.sh
  515. /usr/lib/qubes/init/qubes-sysinit.sh
  516. /usr/lib/qubes/init/bind-dirs.sh
  517. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  518. /lib/systemd/system/crond.service.d/30_qubes.conf
  519. /lib/systemd/system/cups.service.d/30_qubes.conf
  520. /lib/systemd/system/cups.socket.d/30_qubes.conf
  521. /lib/systemd/system/cups.path.d/30_qubes.conf
  522. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  523. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  524. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  525. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  526. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  527. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  528. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  529. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  530. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  531. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  532. /lib/systemd/system/tor.service.d/30_qubes.conf
  533. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  534. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  535. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  536. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  537. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  538. %post systemd
  539. PRESET_FAILED=0
  540. if [ $1 -eq 1 ]; then
  541. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  542. else
  543. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-dirs"
  544. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  545. services="$services qubes-iptables qubes-updates-proxy qubes-qrexec-agent"
  546. for srv in $services; do
  547. /bin/systemctl --no-reload preset $srv.service
  548. done
  549. /bin/systemctl --no-reload preset qubes-update-check.timer
  550. # Upgrade path - now qubes-iptables is used instead
  551. if [ -f /lib/systemd/system/iptables.service ]; then
  552. /bin/systemctl --no-reload preset iptables.service
  553. fi
  554. if [ -f /lib/systemd/system/ip6tables.service ]; then
  555. /bin/systemctl --no-reload preset ip6tables.service
  556. fi
  557. fi
  558. # Set default "runlevel"
  559. rm -f /etc/systemd/system/default.target
  560. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  561. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  562. case "$action" in
  563. (disable)
  564. if [ -f /lib/systemd/system/$unit_name ]; then
  565. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  566. # forcibly disable
  567. ln -sf /dev/null /etc/systemd/system/$unit_name
  568. fi
  569. fi
  570. ;;
  571. *)
  572. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  573. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  574. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  575. fi
  576. ;;
  577. esac
  578. done
  579. # remove old symlinks
  580. if [ -L /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service ]; then
  581. rm /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service
  582. fi
  583. if [ -L /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service ]; then
  584. rm /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service
  585. fi
  586. /bin/systemctl daemon-reload
  587. exit 0
  588. %postun systemd
  589. #Do not run this part on upgrades
  590. if [ "$1" != 0 ] ; then
  591. exit 0
  592. fi
  593. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-netwatcher qubes-network qubes-qrexec-agent; do
  594. /bin/systemctl disable $srv.service
  595. do