core-agent.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. %if %{fedora} < 22
  111. Requires: yum-plugin-post-transaction-actions
  112. %endif
  113. %if %{fedora} >= 18
  114. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  115. Conflicts: firewalld
  116. %endif
  117. Requires: xdg-utils
  118. Requires: qubes-utils >= 3.1.3
  119. Requires: initscripts
  120. Requires: gawk
  121. Requires: sed
  122. Requires: util-linux
  123. # for qubes-desktop-run
  124. Requires: pygobject3-base
  125. Requires: dbus-python
  126. # for qubes-session-autostart, xdg-icon
  127. Requires: pyxdg
  128. Requires: python-daemon
  129. # for qvm-feature-request
  130. Requires: python2-qubesdb
  131. Requires: ImageMagick
  132. Requires: librsvg2-tools
  133. Requires: zenity
  134. Requires: qubes-core-agent-qrexec
  135. Requires: qubes-libvchan
  136. Requires: qubes-db-vm
  137. %if 0%{fedora} >= 23
  138. Requires: python3-dnf-plugins-qubes-hooks
  139. %else
  140. Requires: python2-dnf-plugins-qubes-hooks
  141. %endif
  142. %if 0%{?rhel} >= 7
  143. Requires: python34-dnf-plugins-qubes-hooks
  144. %endif
  145. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  146. Obsoletes: qubes-upgrade-vm < 3.2
  147. Provides: qubes-core-vm = %{version}-%{release}
  148. Obsoletes: qubes-core-vm < 4.0.0
  149. Provides: qubes-core-vm-doc = %{version}-%{release}
  150. Obsoletes: qubes-core-vm-doc < 4.0.0
  151. BuildRequires: pandoc
  152. BuildRequires: xen-devel
  153. BuildRequires: libX11-devel
  154. BuildRequires: qubes-utils-devel >= 3.1.3
  155. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  156. BuildRequires: pam-devel
  157. %description
  158. The Qubes core files for installation inside a Qubes VM.
  159. %package -n python2-dnf-plugins-qubes-hooks
  160. Summary: DNF plugin for Qubes specific post-installation actions
  161. BuildRequires: python2-devel
  162. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  163. %description -n python2-dnf-plugins-qubes-hooks
  164. DNF plugin for Qubes specific post-installation actions:
  165. * notify dom0 that updates were installed
  166. * refresh applications shortcut list
  167. %if 0%{fedora} >= 23
  168. %package -n python3-dnf-plugins-qubes-hooks
  169. Summary: DNF plugin for Qubes specific post-installation actions
  170. BuildRequires: python3-devel
  171. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  172. %description -n python3-dnf-plugins-qubes-hooks
  173. DNF plugin for Qubes specific post-installation actions:
  174. * notify dom0 that updates were installed
  175. * refresh applications shortcut list
  176. %endif
  177. %if 0%{?rhel} >= 7
  178. %package -n python34-dnf-plugins-qubes-hooks
  179. Summary: DNF plugin for Qubes specific post-installation actions
  180. BuildRequires: python34-devel
  181. %{?python_provide:%python_provide python34-dnf-plugins-qubes-hooks}
  182. %description -n python34-dnf-plugins-qubes-hooks
  183. DNF plugin for Qubes specific post-installation actions:
  184. * notify dom0 that updates were installed
  185. * refresh applications shortcut list
  186. %endif
  187. %package qrexec
  188. Summary: Qubes qrexec agent
  189. Requires: qubes-core-agent
  190. Requires: nautilus-python
  191. Conflicts: qubes-core-vm < 4.0.0
  192. %description qrexec
  193. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  194. requested by dom0 or other VMs, according to dom0-enforced policy.
  195. %package nautilus
  196. Summary: Qubes integration for Nautilus
  197. Requires: qubes-core-agent
  198. Requires: nautilus-python
  199. Conflicts: qubes-core-vm < 4.0.0
  200. %description nautilus
  201. Nautilus addons for inter-VM file copy/move/open.
  202. %package dom0-updates
  203. Summary: Scripts required to handle dom0 updates
  204. Requires: qubes-core-agent
  205. Requires: fakeroot
  206. Conflicts: qubes-core-vm < 4.0.0
  207. %description dom0-updates
  208. Scripts required to handle dom0 updates.
  209. %package networking
  210. Summary: Networking support for Qubes VM
  211. Requires: ethtool
  212. Requires: net-tools
  213. Requires: nftables
  214. Requires: socat
  215. Requires: qubes-core-agent
  216. Requires: tinyproxy
  217. Conflicts: qubes-core-vm < 4.0.0
  218. %description networking
  219. This package provides:
  220. * basic network functionality (setting IP address, DNS, default gateway)
  221. * proxy service used by TemplateVMs to download updates
  222. * qubes-firewall service (FirewallVM)
  223. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  224. qubes-core-agent-network-manager.
  225. %package network-manager
  226. Summary: NetworkManager integration for Qubes VM
  227. # to show/hide nm-applet
  228. Requires: NetworkManager >= 0.8.1-1
  229. Requires: glib2
  230. Requires: qubes-core-agent-networking
  231. Conflicts: qubes-core-vm < 4.0.0
  232. %description network-manager
  233. Integration of NetworkManager for Qubes VM:
  234. * make connections config persistent
  235. * adjust DNS redirections when needed
  236. * show/hide NetworkManager applet icon
  237. %package passwordless-root
  238. Summary: Passwordless root access from normal user
  239. Conflicts: qubes-core-vm < 4.0.0
  240. %description passwordless-root
  241. Configure sudo, PolicyKit and similar tool to not ask for any password when
  242. switching from user to root. Since all the user data in a VM is accessible
  243. already from normal user account, there is not much more to guard there. Qubes
  244. VM is a single user system.
  245. %define _builddir %(pwd)
  246. %define kde_service_dir /usr/share/kde4/services
  247. %prep
  248. # we operate on the current directory, so no need to unpack anything
  249. # symlink is to generate useful debuginfo packages
  250. rm -f %{name}-%{version}
  251. ln -sf . %{name}-%{version}
  252. %setup -T -D
  253. %build
  254. for dir in qubes-rpc qrexec misc; do
  255. (cd $dir; make)
  256. done
  257. make -C doc manpages
  258. %pre
  259. # Make sure there is a qubes group
  260. groupadd --force --system --gid 98 qubes
  261. id -u 'user' >/dev/null 2>&1 || {
  262. useradd --user-group --create-home --shell /bin/bash user
  263. }
  264. usermod -a --groups qubes user
  265. if [ "$1" != 1 ] ; then
  266. # do this whole %%pre thing only when updating for the first time...
  267. exit 0
  268. fi
  269. mkdir -p /var/lib/qubes
  270. if [ -e /etc/fstab ] ; then
  271. mv /etc/fstab /var/lib/qubes/fstab.orig
  272. fi
  273. usermod -L user
  274. %pre passwordless-root
  275. usermod -p '' root
  276. %install
  277. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  278. make install-vm DESTDIR=$RPM_BUILD_ROOT
  279. %if %{fedora} >= 22
  280. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  281. %endif
  282. %triggerin -- initscripts
  283. if [ -e /etc/init/serial.conf ]; then
  284. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  285. fi
  286. %triggerin -- grub2-tools
  287. if ! grep -q /etc/default/grub.qubes /etc/default/grub 2>/dev/null; then
  288. # do not keep Qubes-related settings directly in user-controlled config,
  289. # include another file
  290. echo '. /etc/default/grub.qubes' >> /etc/default/grub
  291. fi
  292. %post
  293. # disable some Upstart services
  294. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  295. if [ -e /etc/init/$F.conf ]; then
  296. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  297. fi
  298. done
  299. # Remove old firmware updates link
  300. if [ -L /lib/firmware/updates ]; then
  301. rm -f /lib/firmware/updates
  302. fi
  303. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  304. echo >> /etc/yum.conf
  305. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  306. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  307. fi
  308. # And actually setup the proxy usage in package managers
  309. /usr/lib/qubes/update-proxy-configs
  310. # Location of files which contains list of protected files
  311. mkdir -p /etc/qubes/protected-files.d
  312. . /usr/lib/qubes/init/functions
  313. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  314. if ! is_protected_file /etc/hosts ; then
  315. if ! grep -q localhost /etc/hosts; then
  316. cat <<EOF > /etc/hosts
  317. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  318. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  319. EOF
  320. fi
  321. fi
  322. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  323. # in the form expected by qubes-sysinit.sh
  324. if ! is_protected_file /etc/hostname ; then
  325. for ip in '127\.0\.0\.1' '::1'; do
  326. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  327. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  328. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  329. else
  330. echo "${ip} `hostname`" >> /etc/hosts
  331. fi
  332. done
  333. fi
  334. if [ "$1" != 1 ] ; then
  335. # do the rest of %%post thing only when updating for the first time...
  336. exit 0
  337. fi
  338. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  339. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  340. fi
  341. # Remove most of the udev scripts to speed up the VM boot time
  342. # Just leave the xen* scripts, that are needed if this VM was
  343. # ever used as a net backend (e.g. as a VPN domain in the future)
  344. #echo "--> Removing unnecessary udev scripts..."
  345. mkdir -p /var/lib/qubes/removed-udev-scripts
  346. for f in /etc/udev/rules.d/*
  347. do
  348. if [ $(basename $f) == "xen-backend.rules" ] ; then
  349. continue
  350. fi
  351. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  352. continue
  353. fi
  354. if echo $f | grep -q qubes; then
  355. continue
  356. fi
  357. mv $f /var/lib/qubes/removed-udev-scripts/
  358. done
  359. mkdir -p /rw
  360. #rm -f /etc/mtab
  361. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  362. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  363. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  364. %triggerin -- notification-daemon
  365. # Enable autostart of notification-daemon when installed
  366. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  367. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  368. fi
  369. exit 0
  370. %triggerin -- selinux-policy
  371. #echo "--> Disabling SELinux..."
  372. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  373. mv /etc/selinux/config.processed /etc/selinux/config
  374. setenforce 0 2>/dev/null
  375. exit 0
  376. %post network-manager
  377. # Create NetworkManager configuration if we do not have it
  378. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  379. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  380. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  381. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  382. fi
  383. # Remove ip_forward setting from sysctl, so NM will not reset it
  384. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  385. /usr/lib/qubes/qubes-fix-nm-conf.sh
  386. %post networking
  387. %systemd_post qubes-firewall.service
  388. %systemd_post qubes-iptables.service
  389. %systemd_post qubes-network.service
  390. %systemd_post qubes-updates-proxy.service
  391. %post qrexec
  392. %systemd_post qubes-qrexec-agent.service
  393. %preun
  394. if [ "$1" = 0 ] ; then
  395. # no more packages left
  396. if [ -e /var/lib/qubes/fstab.orig ] ; then
  397. mv /var/lib/qubes/fstab.orig /etc/fstab
  398. fi
  399. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  400. if [ -e /var/lib/qubes/serial.orig ] ; then
  401. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  402. fi
  403. fi
  404. %preun networking
  405. %systemd_preun qubes-firewall.service
  406. %systemd_preun qubes-iptables.service
  407. %systemd_preun qubes-network.service
  408. %systemd_preun qubes-updates-proxy.service
  409. %preun qrexec
  410. %systemd_preun qubes-qrexec-agent.service
  411. %postun
  412. if [ $1 -eq 0 ] ; then
  413. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  414. if [ -L /lib/firmware/updates ]; then
  415. rm /lib/firmware/updates
  416. fi
  417. rm -rf /var/lib/qubes/xdg
  418. fi
  419. %postun passwordless-root
  420. if [ $1 -eq 0 ]; then
  421. usermod -p '*' root
  422. fi
  423. %posttrans
  424. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  425. %clean
  426. rm -rf $RPM_BUILD_ROOT
  427. rm -f %{name}-%{version}
  428. %files
  429. %defattr(-,root,root,-)
  430. %dir /var/lib/qubes
  431. %dir /var/run/qubes
  432. %{kde_service_dir}/qvm-copy.desktop
  433. %{kde_service_dir}/qvm-move.desktop
  434. %{kde_service_dir}/qvm-dvm.desktop
  435. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  436. /etc/fstab
  437. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  438. %dir /etc/qubes-rpc
  439. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  440. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  441. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  442. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  443. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  444. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  445. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  446. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  447. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  448. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  449. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  450. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  451. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  452. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  453. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  454. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  455. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  456. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  457. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  458. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  459. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  460. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  461. %config(noreplace) /etc/qubes-rpc/qubes.GetDate
  462. %dir /etc/qubes/rpc-config
  463. /etc/qubes/rpc-config/README
  464. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenInVM
  465. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenURL
  466. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectFile
  467. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectDirectory
  468. %config(noreplace) /etc/qubes/rpc-config/qubes.StartApp
  469. %config(noreplace) /etc/qubes/rpc-config/qubes.InstallUpdatesGUI
  470. %dir /etc/qubes/autostart
  471. %config(noreplace) /etc/default/grub.qubes
  472. /etc/qubes/autostart/README.txt
  473. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  474. %dir /etc/qubes/suspend-pre.d
  475. /etc/qubes/suspend-pre.d/README
  476. %dir /etc/qubes/suspend-post.d
  477. /etc/qubes/suspend-post.d/README
  478. /etc/qubes/suspend-post.d/qvm-sync-clock.sh
  479. %dir /etc/qubes/post-install.d
  480. /etc/qubes/post-install.d/README
  481. /etc/qubes/post-install.d/*.sh
  482. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  483. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  484. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  485. %config(noreplace) /etc/qubes-suspend-module-blacklist
  486. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  487. %config(noreplace) /etc/yum.repos.d/qubes-r4.repo
  488. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  489. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  490. %if %{fedora} < 22
  491. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  492. %endif
  493. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  494. /usr/sbin/qubes-serial-login
  495. /usr/bin/qvm-copy-to-vm
  496. /usr/bin/qvm-move-to-vm
  497. /usr/bin/qvm-open-in-dvm
  498. /usr/bin/qvm-open-in-vm
  499. /usr/bin/qvm-run-vm
  500. /usr/bin/qvm-features-request
  501. /usr/bin/qvm-sync-clock
  502. /usr/bin/xenstore-watch-qubes
  503. /usr/bin/qubes-desktop-run
  504. /usr/bin/qubes-open
  505. /usr/bin/qubes-session-autostart
  506. %dir /usr/lib/qubes
  507. /usr/lib/qubes/prepare-suspend
  508. /usr/lib/qubes/qfile-agent
  509. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  510. /usr/lib/qubes/qopen-in-vm
  511. /usr/lib/qubes/qrun-in-vm
  512. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  513. /usr/lib/qubes/qvm-copy-to-vm.kde
  514. /usr/lib/qubes/qvm-move-to-vm.kde
  515. /usr/lib/qubes/tar2qfile
  516. /usr/lib/qubes/vm-file-editor
  517. /usr/lib/qubes/close-window
  518. /usr/lib/qubes/xdg-icon
  519. /usr/lib/qubes/update-proxy-configs
  520. /usr/lib/qubes/upgrades-installed-check
  521. /usr/lib/qubes/upgrades-status-notify
  522. /usr/lib/qubes/qubes-sync-clock
  523. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  524. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  525. %dir /usr/lib/qubes/init
  526. /usr/lib/qubes/init/bind-dirs.sh
  527. /usr/lib/qubes/init/control-printer-icon.sh
  528. /usr/lib/qubes/init/functions
  529. /usr/lib/qubes/init/misc-post-stop.sh
  530. /usr/lib/qubes/init/misc-post.sh
  531. /usr/lib/qubes/init/mount-dirs.sh
  532. /usr/lib/qubes/init/qubes-early-vm-config.sh
  533. /usr/lib/qubes/init/qubes-random-seed.sh
  534. /usr/lib/qubes/init/qubes-sysinit.sh
  535. /usr/lib/qubes/init/setup-rw.sh
  536. /usr/lib/qubes/init/setup-rwdev.sh
  537. /usr/lib/qubes/init/functions
  538. %dir /usr/lib/qubes-bind-dirs.d
  539. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  540. /usr/lib/python2.7/site-packages/qubesxdg.py*
  541. /usr/share/qubes/serial.conf
  542. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  543. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  544. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  545. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  546. %{_mandir}/man1/qvm-*.1*
  547. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  548. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  549. %dir %{python_sitelib}/qubesagent
  550. %{python_sitelib}/qubesagent/__init__.py*
  551. %{python_sitelib}/qubesagent/firewall.py*
  552. %{python_sitelib}/qubesagent/test_firewall.py*
  553. /usr/share/qubes/mime-override/globs
  554. /usr/share/qubes/qubes-master-key.asc
  555. %dir /mnt/removable
  556. %dir /rw
  557. %files -n python2-dnf-plugins-qubes-hooks
  558. %{python2_sitelib}/dnf-plugins/*
  559. %if 0%{fedora} >= 23
  560. %files -n python3-dnf-plugins-qubes-hooks
  561. %{python3_sitelib}/dnf-plugins/*
  562. %endif
  563. %if 0%{?rhel} >= 7
  564. %files -n python34-dnf-plugins-qubes-hooks
  565. %{python3_sitelib}/dnf-plugins/*
  566. %endif
  567. %files qrexec
  568. %config(noreplace) /etc/pam.d/qrexec
  569. /usr/bin/qrexec-fork-server
  570. /usr/bin/qrexec-client-vm
  571. /usr/lib/qubes/qrexec-agent
  572. /usr/lib/qubes/qrexec-client-vm
  573. /usr/lib/qubes/qrexec_client_vm
  574. /usr/lib/qubes/qubes-rpc-multiplexer
  575. /lib/systemd/system/qubes-qrexec-agent.service
  576. %{_mandir}/man1/qrexec-client-vm.1*
  577. %files nautilus
  578. /usr/lib/qubes/qvm-copy-to-vm.gnome
  579. /usr/lib/qubes/qvm-move-to-vm.gnome
  580. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  581. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  582. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  583. %files dom0-updates
  584. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  585. /usr/lib/qubes/qubes-download-dom0-updates.sh
  586. %files networking
  587. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  588. %config(noreplace) /etc/qubes/ip6tables.rules
  589. %config(noreplace) /etc/qubes/iptables.rules
  590. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  591. %config(noreplace) /etc/tinyproxy/updates-blacklist
  592. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  593. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  594. /etc/xen/scripts/vif-qubes-nat.sh
  595. /etc/xen/scripts/vif-route-qubes
  596. /lib/systemd/system/qubes-firewall.service
  597. /lib/systemd/system/qubes-iptables.service
  598. /lib/systemd/system/qubes-network.service
  599. /lib/systemd/system/qubes-updates-proxy.service
  600. /usr/lib/qubes/init/network-proxy-setup.sh
  601. /usr/lib/qubes/init/qubes-iptables
  602. /usr/lib/qubes/iptables-updates-proxy
  603. /usr/lib/qubes/qubes-setup-dnat-to-ns
  604. /usr/lib/qubes/setup-ip
  605. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  606. /usr/sbin/qubes-firewall
  607. %files network-manager
  608. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  609. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  610. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  611. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  612. /usr/lib/qubes/network-manager-prepare-conf-dir
  613. /usr/lib/qubes/qubes-fix-nm-conf.sh
  614. /usr/lib/qubes/show-hide-nm-applet.sh
  615. %files passwordless-root
  616. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  617. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  618. %config(noreplace) /etc/sudoers.d/qubes
  619. %package sysvinit
  620. Summary: Qubes unit files for SysV init style or upstart
  621. License: GPL v2 only
  622. Group: Qubes
  623. Requires: upstart
  624. Requires: qubes-core-agent
  625. Requires: qubes-core-agent-qrexec
  626. Requires: qubes-core-agent-networking
  627. Provides: qubes-core-agent-init-scripts
  628. Conflicts: qubes-core-agent-systemd
  629. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  630. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  631. %description sysvinit
  632. The Qubes core startup configuration for SysV init (or upstart).
  633. %files sysvinit
  634. /etc/init.d/qubes-sysinit
  635. /etc/init.d/qubes-core-early
  636. /etc/init.d/qubes-core
  637. /etc/init.d/qubes-core-netvm
  638. /etc/init.d/qubes-firewall
  639. /etc/init.d/qubes-iptables
  640. /etc/init.d/qubes-updates-proxy
  641. /etc/init.d/qubes-qrexec-agent
  642. /etc/init.d/qubes-updates-proxy-forwarder
  643. /etc/sysconfig/modules/qubes-core.modules
  644. %post sysvinit
  645. #echo "--> Turning off unnecessary services..."
  646. # FIXME: perhaps there is more elegant way to do this?
  647. for f in /etc/init.d/*
  648. do
  649. srv=`basename $f`
  650. [ $srv = 'functions' ] && continue
  651. [ $srv = 'killall' ] && continue
  652. [ $srv = 'halt' ] && continue
  653. [ $srv = 'single' ] && continue
  654. [ $srv = 'reboot' ] && continue
  655. [ $srv = 'qubes-gui' ] && continue
  656. chkconfig $srv off
  657. done
  658. #echo "--> Enabling essential services..."
  659. chkconfig rsyslog on
  660. chkconfig haldaemon on
  661. chkconfig messagebus on
  662. for svc in %qubes_services ; do
  663. if [ "$1" = 1 ] ; then
  664. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  665. else
  666. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  667. fi
  668. done
  669. # dropped services
  670. chkconfig qubes-netwatcher off || :
  671. # TODO: make this not display the silly message about security context...
  672. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  673. %preun sysvinit
  674. if [ "$1" = 0 ] ; then
  675. # no more packages left
  676. for svc in %qubes_services ; do
  677. chkconfig --del $svc
  678. done
  679. fi
  680. %package systemd
  681. Summary: Qubes unit files for SystemD init style
  682. License: GPL v2 only
  683. Group: Qubes
  684. Requires: systemd
  685. Requires(post): systemd-units
  686. Requires(preun): systemd-units
  687. Requires(postun): systemd-units
  688. Requires: qubes-core-agent
  689. Provides: qubes-core-agent-init-scripts
  690. Conflicts: qubes-core-agent-sysvinit
  691. Provides: qubes-core-vm-systemd = %{version}-%{release}
  692. Obsoletes: qubes-core-vm-systemd < 4.0.0
  693. %description systemd
  694. The Qubes core startup configuration for SystemD init.
  695. %files systemd
  696. %defattr(-,root,root,-)
  697. /lib/systemd/system/qubes-misc-post.service
  698. /lib/systemd/system/qubes-mount-dirs.service
  699. /lib/systemd/system/qubes-sysinit.service
  700. /lib/systemd/system/qubes-early-vm-config.service
  701. /lib/systemd/system/qubes-update-check.service
  702. /lib/systemd/system/qubes-update-check.timer
  703. /lib/systemd/system/qubes-sync-time.service
  704. /lib/systemd/system/qubes-sync-time.timer
  705. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  706. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  707. /lib/systemd/system-preset/%qubes_preset_file
  708. /lib/modules-load.d/qubes-core.conf
  709. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  710. /lib/systemd/system/crond.service.d/30_qubes.conf
  711. /lib/systemd/system/cups.service.d/30_qubes.conf
  712. /lib/systemd/system/cups.socket.d/30_qubes.conf
  713. /lib/systemd/system/cups.path.d/30_qubes.conf
  714. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  715. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  716. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  717. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  718. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  719. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  720. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  721. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  722. /lib/systemd/system/systemd-timesyncd.service.d/30_qubes.conf
  723. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  724. /lib/systemd/system/tor.service.d/30_qubes.conf
  725. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  726. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  727. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  728. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  729. %post systemd
  730. changed=
  731. %scriptletfuns
  732. if [ $1 -eq 1 ]
  733. then
  734. preset_units %{_presetdir}/%qubes_preset_file initial
  735. changed=true
  736. else
  737. preset_units %{_presetdir}/%qubes_preset_file upgrade
  738. changed=true
  739. # Upgrade path - now qubes-iptables is used instead
  740. for svc in iptables ip6tables
  741. do
  742. if [ -f "$svc".service ]
  743. then
  744. systemctl --no-reload preset "$svc".service
  745. changed=true
  746. fi
  747. done
  748. fi
  749. if [ $1 -eq 1 ]
  750. then
  751. # First install.
  752. # Set default "runlevel".
  753. # FIXME: this ought to be done via kernel command line.
  754. # The fewer deviations of the template from the seed
  755. # image, the better.
  756. rm -f %{_sysconfdir}/systemd/system/default.target
  757. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  758. changed=true
  759. fi
  760. # remove old symlinks
  761. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  762. then
  763. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  764. changed=true
  765. fi
  766. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  767. then
  768. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  769. changed=true
  770. fi
  771. if [ "x$changed" != "x" ]
  772. then
  773. systemctl daemon-reload
  774. fi
  775. %preun systemd
  776. if [ $1 -eq 0 ] ; then
  777. # Run this only during uninstall.
  778. # Save the preset file to later use it to re-preset services there
  779. # once the Qubes OS preset file is removed.
  780. mkdir -p %{_rundir}/qubes-uninstall
  781. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  782. fi
  783. %postun systemd
  784. changed=
  785. %scriptletfuns
  786. if [ -d %{_rundir}/qubes-uninstall ]
  787. then
  788. # We have a saved preset file (or more).
  789. # Re-preset the units mentioned there.
  790. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  791. rm -rf %{_rundir}/qubes-uninstall
  792. changed=true
  793. fi
  794. if [ "x$changed" != "x" ]
  795. then
  796. systemctl daemon-reload
  797. fi