core-agent.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: ntpdate
  120. Requires: qubes-utils >= 3.1.3
  121. Requires: initscripts
  122. Requires: gawk
  123. Requires: sed
  124. Requires: util-linux
  125. # for qubes-desktop-run
  126. Requires: pygobject3-base
  127. Requires: dbus-python
  128. # for qubes-session-autostart, xdg-icon
  129. Requires: pyxdg
  130. Requires: python-daemon
  131. # for qvm-feature-request
  132. Requires: python2-qubesdb
  133. Requires: ImageMagick
  134. Requires: librsvg2-tools
  135. Requires: zenity
  136. Requires: qubes-core-agent-qrexec
  137. Requires: qubes-libvchan
  138. Requires: qubes-db-vm
  139. %if 0%{fedora} >= 23
  140. Requires: python3-dnf-plugins-qubes-hooks
  141. %else
  142. Requires: python2-dnf-plugins-qubes-hooks
  143. %endif
  144. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  145. Obsoletes: qubes-upgrade-vm < 3.2
  146. Provides: qubes-core-vm = %{version}-%{release}
  147. Obsoletes: qubes-core-vm < 4.0.0
  148. Provides: qubes-core-vm-doc = %{version}-%{release}
  149. Obsoletes: qubes-core-vm-doc < 4.0.0
  150. BuildRequires: pandoc
  151. BuildRequires: xen-devel
  152. BuildRequires: libX11-devel
  153. BuildRequires: qubes-utils-devel >= 3.1.3
  154. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  155. %description
  156. The Qubes core files for installation inside a Qubes VM.
  157. %package -n python2-dnf-plugins-qubes-hooks
  158. Summary: DNF plugin for Qubes specific post-installation actions
  159. BuildRequires: python2-devel
  160. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  161. %description -n python2-dnf-plugins-qubes-hooks
  162. DNF plugin for Qubes specific post-installation actions:
  163. * notify dom0 that updates were installed
  164. * refresh applications shortcut list
  165. %package -n python3-dnf-plugins-qubes-hooks
  166. Summary: DNF plugin for Qubes specific post-installation actions
  167. BuildRequires: python3-devel
  168. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  169. %description -n python3-dnf-plugins-qubes-hooks
  170. DNF plugin for Qubes specific post-installation actions:
  171. * notify dom0 that updates were installed
  172. * refresh applications shortcut list
  173. %package qrexec
  174. Summary: Qubes qrexec agent
  175. Requires: qubes-core-agent
  176. Requires: nautilus-python
  177. Conflicts: qubes-core-vm < 4.0.0
  178. %description qrexec
  179. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  180. requested by dom0 or other VMs, according to dom0-enforced policy.
  181. %package nautilus
  182. Summary: Qubes integration for Nautilus
  183. Requires: qubes-core-agent
  184. Requires: nautilus-python
  185. Conflicts: qubes-core-vm < 4.0.0
  186. %description nautilus
  187. Nautilus addons for inter-VM file copy/move/open.
  188. %package dom0-updates
  189. Summary: Scripts required to handle dom0 updates
  190. Requires: qubes-core-agent
  191. Requires: fakeroot
  192. Conflicts: qubes-core-vm < 4.0.0
  193. %description dom0-updates
  194. Scripts required to handle dom0 updates.
  195. %package networking
  196. Summary: Networking support for Qubes VM
  197. Requires: ethtool
  198. Requires: net-tools
  199. Requires: nftables
  200. Requires: socat
  201. Requires: qubes-core-agent
  202. Requires: tinyproxy
  203. Conflicts: qubes-core-vm < 4.0.0
  204. %description networking
  205. This package provides:
  206. * basic network functionality (setting IP address, DNS, default gateway)
  207. * proxy service used by TemplateVMs to download updates
  208. * qubes-firewall service (FirewallVM)
  209. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  210. qubes-core-agent-network-manager.
  211. %package network-manager
  212. Summary: NetworkManager integration for Qubes VM
  213. # to show/hide nm-applet
  214. Requires: NetworkManager >= 0.8.1-1
  215. Requires: glib2
  216. Requires: qubes-core-agent-networking
  217. Conflicts: qubes-core-vm < 4.0.0
  218. %description network-manager
  219. Integration of NetworkManager for Qubes VM:
  220. * make connections config persistent
  221. * adjust DNS redirections when needed
  222. * show/hide NetworkManager applet icon
  223. %package passwordless-root
  224. Summary: Passwordless root access from normal user
  225. Conflicts: qubes-core-vm < 4.0.0
  226. %description passwordless-root
  227. Configure sudo, PolicyKit and similar tool to not ask for any password when
  228. switching from user to root. Since all the user data in a VM is accessible
  229. already from normal user account, there is not much more to guard there. Qubes
  230. VM is a single user system.
  231. %define _builddir %(pwd)
  232. %define kde_service_dir /usr/share/kde4/services
  233. %prep
  234. # we operate on the current directory, so no need to unpack anything
  235. # symlink is to generate useful debuginfo packages
  236. rm -f %{name}-%{version}
  237. ln -sf . %{name}-%{version}
  238. %setup -T -D
  239. %build
  240. for dir in qubes-rpc qrexec misc; do
  241. (cd $dir; make)
  242. done
  243. make -C doc manpages
  244. %pre
  245. # Make sure there is a qubes group
  246. groupadd --force --system --gid 98 qubes
  247. id -u 'user' >/dev/null 2>&1 || {
  248. useradd --user-group --create-home --shell /bin/bash user
  249. }
  250. usermod -a --groups qubes user
  251. if [ "$1" != 1 ] ; then
  252. # do this whole %%pre thing only when updating for the first time...
  253. exit 0
  254. fi
  255. mkdir -p /var/lib/qubes
  256. if [ -e /etc/fstab ] ; then
  257. mv /etc/fstab /var/lib/qubes/fstab.orig
  258. fi
  259. usermod -L user
  260. %pre passwordless-root
  261. usermod -p '' root
  262. %install
  263. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  264. make install-vm DESTDIR=$RPM_BUILD_ROOT
  265. make -C doc install DESTDIR=$RPM_BUILD_ROOT
  266. %if %{fedora} >= 22
  267. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  268. %endif
  269. %triggerin -- initscripts
  270. if [ -e /etc/init/serial.conf ]; then
  271. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  272. fi
  273. %triggerin -- grub2-tools
  274. if ! grep -q /etc/default/grub.qubes /etc/default/grub 2>/dev/null; then
  275. # do not keep Qubes-related settings directly in user-controlled config,
  276. # include another file
  277. echo '. /etc/default/grub.qubes' >> /etc/default/grub
  278. fi
  279. %post
  280. # disable some Upstart services
  281. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  282. if [ -e /etc/init/$F.conf ]; then
  283. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  284. fi
  285. done
  286. # Remove old firmware updates link
  287. if [ -L /lib/firmware/updates ]; then
  288. rm -f /lib/firmware/updates
  289. fi
  290. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  291. echo >> /etc/yum.conf
  292. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  293. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  294. fi
  295. # And actually setup the proxy usage in package managers
  296. /usr/lib/qubes/update-proxy-configs
  297. # Location of files which contains list of protected files
  298. mkdir -p /etc/qubes/protected-files.d
  299. . /usr/lib/qubes/init/functions
  300. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  301. if ! is_protected_file /etc/hosts ; then
  302. if ! grep -q localhost /etc/hosts; then
  303. cat <<EOF > /etc/hosts
  304. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  305. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  306. EOF
  307. fi
  308. fi
  309. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  310. # in the form expected by qubes-sysinit.sh
  311. if ! is_protected_file /etc/hostname ; then
  312. for ip in '127\.0\.0\.1' '::1'; do
  313. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  314. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  315. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  316. else
  317. echo "${ip} `hostname`" >> /etc/hosts
  318. fi
  319. done
  320. fi
  321. %if %{fedora} >= 20
  322. # Make sure there is a default locale set so gnome-terminal will start
  323. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  324. touch /etc/locale.conf
  325. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  326. fi
  327. # ... and make sure it is really generated
  328. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  329. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  330. base=`echo "$current_locale" | cut -f 1 -d .`
  331. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  332. [ -n "$charmap" ] && charmap="-f $charmap"
  333. localedef -i $base $charmap $current_locale
  334. fi
  335. %endif
  336. if [ "$1" != 1 ] ; then
  337. # do the rest of %%post thing only when updating for the first time...
  338. exit 0
  339. fi
  340. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  341. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  342. fi
  343. # Remove most of the udev scripts to speed up the VM boot time
  344. # Just leave the xen* scripts, that are needed if this VM was
  345. # ever used as a net backend (e.g. as a VPN domain in the future)
  346. #echo "--> Removing unnecessary udev scripts..."
  347. mkdir -p /var/lib/qubes/removed-udev-scripts
  348. for f in /etc/udev/rules.d/*
  349. do
  350. if [ $(basename $f) == "xen-backend.rules" ] ; then
  351. continue
  352. fi
  353. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  354. continue
  355. fi
  356. if echo $f | grep -q qubes; then
  357. continue
  358. fi
  359. mv $f /var/lib/qubes/removed-udev-scripts/
  360. done
  361. mkdir -p /rw
  362. #rm -f /etc/mtab
  363. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  364. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  365. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  366. %triggerin -- notification-daemon
  367. # Enable autostart of notification-daemon when installed
  368. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  369. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  370. fi
  371. exit 0
  372. %triggerin -- selinux-policy
  373. #echo "--> Disabling SELinux..."
  374. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  375. mv /etc/selinux/config.processed /etc/selinux/config
  376. setenforce 0 2>/dev/null
  377. exit 0
  378. %post network-manager
  379. # Create NetworkManager configuration if we do not have it
  380. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  381. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  382. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  383. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  384. fi
  385. # Remove ip_forward setting from sysctl, so NM will not reset it
  386. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  387. /usr/lib/qubes/qubes-fix-nm-conf.sh
  388. %preun
  389. if [ "$1" = 0 ] ; then
  390. # no more packages left
  391. if [ -e /var/lib/qubes/fstab.orig ] ; then
  392. mv /var/lib/qubes/fstab.orig /etc/fstab
  393. fi
  394. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  395. if [ -e /var/lib/qubes/serial.orig ] ; then
  396. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  397. fi
  398. fi
  399. %postun
  400. if [ $1 -eq 0 ] ; then
  401. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  402. if [ -L /lib/firmware/updates ]; then
  403. rm /lib/firmware/updates
  404. fi
  405. rm -rf /var/lib/qubes/xdg
  406. fi
  407. %postun passwordless-root
  408. if [ $1 -eq 0 ]; then
  409. usermod -p '*' root
  410. fi
  411. %posttrans
  412. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  413. %clean
  414. rm -rf $RPM_BUILD_ROOT
  415. rm -f %{name}-%{version}
  416. %files
  417. %defattr(-,root,root,-)
  418. %dir /var/lib/qubes
  419. %dir /var/run/qubes
  420. %{kde_service_dir}/qvm-copy.desktop
  421. %{kde_service_dir}/qvm-move.desktop
  422. %{kde_service_dir}/qvm-dvm.desktop
  423. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  424. /etc/fstab
  425. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  426. %dir /etc/qubes-rpc
  427. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  428. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  429. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  430. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  431. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  432. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  433. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  434. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  435. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  436. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  437. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  438. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  439. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  440. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  441. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  442. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  443. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  444. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  445. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  446. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  447. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  448. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  449. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  450. %dir /etc/qubes/autostart
  451. %config(noreplace) /etc/default/grub.qubes
  452. /etc/qubes/autostart/README.txt
  453. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  454. %dir /etc/qubes/suspend-pre.d
  455. /etc/qubes/suspend-pre.d/README
  456. %dir /etc/qubes/suspend-post.d
  457. /etc/qubes/suspend-post.d/README
  458. %dir /etc/qubes/post-install.d
  459. /etc/qubes/post-install.d/README
  460. /etc/qubes/post-install.d/*.sh
  461. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  462. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  463. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  464. %config(noreplace) /etc/qubes-suspend-module-blacklist
  465. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  466. %config(noreplace) /etc/yum.repos.d/qubes-r4.repo
  467. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  468. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  469. %if %{fedora} < 22
  470. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  471. %endif
  472. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  473. /usr/sbin/qubes-serial-login
  474. /usr/bin/qvm-copy-to-vm
  475. /usr/bin/qvm-move-to-vm
  476. /usr/bin/qvm-open-in-dvm
  477. /usr/bin/qvm-open-in-vm
  478. /usr/bin/qvm-run-vm
  479. /usr/bin/qvm-features-request
  480. /usr/bin/xenstore-watch-qubes
  481. /usr/bin/qubes-desktop-run
  482. /usr/bin/qubes-open
  483. /usr/bin/qubes-session-autostart
  484. %dir /usr/lib/qubes
  485. /usr/lib/qubes/sync-ntp-clock
  486. /usr/lib/qubes/prepare-suspend
  487. /usr/lib/qubes/qfile-agent
  488. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  489. /usr/lib/qubes/qopen-in-vm
  490. /usr/lib/qubes/qrun-in-vm
  491. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  492. /usr/lib/qubes/qvm-copy-to-vm.kde
  493. /usr/lib/qubes/qvm-move-to-vm.kde
  494. /usr/lib/qubes/tar2qfile
  495. /usr/lib/qubes/vm-file-editor
  496. /usr/lib/qubes/close-window
  497. /usr/lib/qubes/xdg-icon
  498. /usr/lib/qubes/update-proxy-configs
  499. /usr/lib/qubes/upgrades-installed-check
  500. /usr/lib/qubes/upgrades-status-notify
  501. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  502. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  503. %dir /usr/lib/qubes/init
  504. /usr/lib/qubes/init/bind-dirs.sh
  505. /usr/lib/qubes/init/control-printer-icon.sh
  506. /usr/lib/qubes/init/functions
  507. /usr/lib/qubes/init/misc-post-stop.sh
  508. /usr/lib/qubes/init/misc-post.sh
  509. /usr/lib/qubes/init/mount-dirs.sh
  510. /usr/lib/qubes/init/qubes-early-vm-config.sh
  511. /usr/lib/qubes/init/qubes-random-seed.sh
  512. /usr/lib/qubes/init/qubes-sysinit.sh
  513. /usr/lib/qubes/init/setup-rw.sh
  514. /usr/lib/qubes/init/setup-rwdev.sh
  515. /usr/lib/qubes/init/functions
  516. %dir /usr/lib/qubes-bind-dirs.d
  517. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  518. /usr/lib/python2.7/site-packages/qubesxdg.py*
  519. /usr/share/qubes/serial.conf
  520. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  521. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  522. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  523. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  524. %{_mandir}/man1/qvm-*.1*
  525. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  526. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  527. %dir %{python_sitelib}/qubesagent
  528. %{python_sitelib}/qubesagent/__init__.py*
  529. %{python_sitelib}/qubesagent/firewall.py*
  530. %{python_sitelib}/qubesagent/test_firewall.py*
  531. /usr/share/qubes/mime-override/globs
  532. /usr/share/qubes/qubes-master-key.asc
  533. %dir /mnt/removable
  534. %dir /rw
  535. %files -n python2-dnf-plugins-qubes-hooks
  536. %{python2_sitelib}/dnf-plugins/*
  537. %files -n python3-dnf-plugins-qubes-hooks
  538. %{python3_sitelib}/dnf-plugins/*
  539. %files qrexec
  540. /usr/bin/qrexec-fork-server
  541. /usr/bin/qrexec-client-vm
  542. /usr/lib/qubes/qrexec-agent
  543. /usr/lib/qubes/qrexec-client-vm
  544. /usr/lib/qubes/qrexec_client_vm
  545. /usr/lib/qubes/qubes-rpc-multiplexer
  546. /lib/systemd/system/qubes-qrexec-agent.service
  547. %files nautilus
  548. /usr/lib/qubes/qvm-copy-to-vm.gnome
  549. /usr/lib/qubes/qvm-move-to-vm.gnome
  550. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  551. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  552. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  553. %files dom0-updates
  554. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  555. /usr/lib/qubes/qubes-download-dom0-updates.sh
  556. %files networking
  557. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  558. %config(noreplace) /etc/qubes/ip6tables.rules
  559. %config(noreplace) /etc/qubes/iptables.rules
  560. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  561. %config(noreplace) /etc/tinyproxy/updates-blacklist
  562. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  563. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  564. /etc/xen/scripts/vif-qubes-nat.sh
  565. /etc/xen/scripts/vif-route-qubes
  566. /lib/systemd/system/qubes-firewall.service
  567. /lib/systemd/system/qubes-iptables.service
  568. /lib/systemd/system/qubes-network.service
  569. /lib/systemd/system/qubes-updates-proxy.service
  570. /usr/lib/qubes/init/network-proxy-setup.sh
  571. /usr/lib/qubes/init/qubes-iptables
  572. /usr/lib/qubes/iptables-updates-proxy
  573. /usr/lib/qubes/qubes-setup-dnat-to-ns
  574. /usr/lib/qubes/setup-ip
  575. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  576. /usr/sbin/qubes-firewall
  577. %files network-manager
  578. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  579. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  580. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  581. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  582. /usr/lib/qubes/network-manager-prepare-conf-dir
  583. /usr/lib/qubes/qubes-fix-nm-conf.sh
  584. /usr/lib/qubes/show-hide-nm-applet.sh
  585. %files passwordless-root
  586. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  587. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  588. %config(noreplace) /etc/sudoers.d/qubes
  589. %package sysvinit
  590. Summary: Qubes unit files for SysV init style or upstart
  591. License: GPL v2 only
  592. Group: Qubes
  593. Requires: upstart
  594. Requires: qubes-core-agent
  595. Requires: qubes-core-agent-qrexec
  596. Requires: qubes-core-agent-networking
  597. Provides: qubes-core-agent-init-scripts
  598. Conflicts: qubes-core-agent-systemd
  599. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  600. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  601. %description sysvinit
  602. The Qubes core startup configuration for SysV init (or upstart).
  603. %files sysvinit
  604. /etc/init.d/qubes-sysinit
  605. /etc/init.d/qubes-core-early
  606. /etc/init.d/qubes-core
  607. /etc/init.d/qubes-core-netvm
  608. /etc/init.d/qubes-firewall
  609. /etc/init.d/qubes-iptables
  610. /etc/init.d/qubes-updates-proxy
  611. /etc/init.d/qubes-qrexec-agent
  612. /etc/init.d/qubes-updates-proxy-forwarder
  613. /etc/sysconfig/modules/qubes-core.modules
  614. /etc/sysconfig/modules/qubes-misc.modules
  615. %post sysvinit
  616. #echo "--> Turning off unnecessary services..."
  617. # FIXME: perhaps there is more elegant way to do this?
  618. for f in /etc/init.d/*
  619. do
  620. srv=`basename $f`
  621. [ $srv = 'functions' ] && continue
  622. [ $srv = 'killall' ] && continue
  623. [ $srv = 'halt' ] && continue
  624. [ $srv = 'single' ] && continue
  625. [ $srv = 'reboot' ] && continue
  626. [ $srv = 'qubes-gui' ] && continue
  627. chkconfig $srv off
  628. done
  629. #echo "--> Enabling essential services..."
  630. chkconfig rsyslog on
  631. chkconfig haldaemon on
  632. chkconfig messagebus on
  633. for svc in %qubes_services ; do
  634. if [ "$1" = 1 ] ; then
  635. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  636. else
  637. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  638. fi
  639. done
  640. # dropped services
  641. chkconfig qubes-netwatcher off || :
  642. # TODO: make this not display the silly message about security context...
  643. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  644. %preun sysvinit
  645. if [ "$1" = 0 ] ; then
  646. # no more packages left
  647. for svc in %qubes_services ; do
  648. chkconfig --del $svc
  649. done
  650. fi
  651. %package systemd
  652. Summary: Qubes unit files for SystemD init style
  653. License: GPL v2 only
  654. Group: Qubes
  655. Requires: systemd
  656. Requires(post): systemd-units
  657. Requires(preun): systemd-units
  658. Requires(postun): systemd-units
  659. Requires: qubes-core-agent
  660. Provides: qubes-core-agent-init-scripts
  661. Conflicts: qubes-core-agent-sysvinit
  662. Provides: qubes-core-vm-systemd = %{version}-%{release}
  663. Obsoletes: qubes-core-vm-systemd < 4.0.0
  664. %description systemd
  665. The Qubes core startup configuration for SystemD init.
  666. %files systemd
  667. %defattr(-,root,root,-)
  668. /lib/systemd/system/qubes-misc-post.service
  669. /lib/systemd/system/qubes-mount-dirs.service
  670. /lib/systemd/system/qubes-sysinit.service
  671. /lib/systemd/system/qubes-early-vm-config.service
  672. /lib/systemd/system/qubes-update-check.service
  673. /lib/systemd/system/qubes-update-check.timer
  674. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  675. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  676. /lib/systemd/system-preset/%qubes_preset_file
  677. /lib/modules-load.d/qubes-core.conf
  678. /lib/modules-load.d/qubes-misc.conf
  679. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  680. /lib/systemd/system/crond.service.d/30_qubes.conf
  681. /lib/systemd/system/cups.service.d/30_qubes.conf
  682. /lib/systemd/system/cups.socket.d/30_qubes.conf
  683. /lib/systemd/system/cups.path.d/30_qubes.conf
  684. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  685. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  686. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  687. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  688. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  689. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  690. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  691. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  692. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  693. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  694. /lib/systemd/system/tor.service.d/30_qubes.conf
  695. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  696. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  697. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  698. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  699. %post systemd
  700. changed=
  701. %scriptletfuns
  702. if [ $1 -eq 1 ]
  703. then
  704. preset_units %{_presetdir}/%qubes_preset_file initial
  705. changed=true
  706. else
  707. preset_units %{_presetdir}/%qubes_preset_file upgrade
  708. changed=true
  709. # Upgrade path - now qubes-iptables is used instead
  710. for svc in iptables ip6tables
  711. do
  712. if [ -f "$svc".service ]
  713. then
  714. systemctl --no-reload preset "$svc".service
  715. changed=true
  716. fi
  717. done
  718. fi
  719. if [ $1 -eq 1 ]
  720. then
  721. # First install.
  722. # Set default "runlevel".
  723. # FIXME: this ought to be done via kernel command line.
  724. # The fewer deviations of the template from the seed
  725. # image, the better.
  726. rm -f %{_sysconfdir}/systemd/system/default.target
  727. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  728. changed=true
  729. fi
  730. # remove old symlinks
  731. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  732. then
  733. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  734. changed=true
  735. fi
  736. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  737. then
  738. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  739. changed=true
  740. fi
  741. if [ "x$changed" != "x" ]
  742. then
  743. systemctl daemon-reload
  744. fi
  745. %preun systemd
  746. if [ $1 -eq 0 ] ; then
  747. # Run this only during uninstall.
  748. # Save the preset file to later use it to re-preset services there
  749. # once the Qubes OS preset file is removed.
  750. mkdir -p %{_rundir}/qubes-uninstall
  751. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  752. fi
  753. %postun systemd
  754. changed=
  755. %scriptletfuns
  756. if [ -d %{_rundir}/qubes-uninstall ]
  757. then
  758. # We have a saved preset file (or more).
  759. # Re-preset the units mentioned there.
  760. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  761. rm -rf %{_rundir}/qubes-uninstall
  762. changed=true
  763. fi
  764. if [ "x$changed" != "x" ]
  765. then
  766. systemctl daemon-reload
  767. fi