core-agent.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: qubes-utils >= 3.1.3
  120. Requires: initscripts
  121. Requires: gawk
  122. Requires: sed
  123. Requires: util-linux
  124. # for qubes-desktop-run
  125. Requires: pygobject3-base
  126. Requires: dbus-python
  127. # for qubes-session-autostart, xdg-icon
  128. Requires: pyxdg
  129. Requires: python-daemon
  130. # for qvm-feature-request
  131. Requires: python2-qubesdb
  132. Requires: ImageMagick
  133. Requires: librsvg2-tools
  134. Requires: zenity
  135. Requires: qubes-core-agent-qrexec
  136. Requires: qubes-libvchan
  137. Requires: qubes-db-vm
  138. %if 0%{fedora} >= 23
  139. Requires: python3-dnf-plugins-qubes-hooks
  140. %else
  141. Requires: python2-dnf-plugins-qubes-hooks
  142. %endif
  143. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  144. Obsoletes: qubes-upgrade-vm < 3.2
  145. Provides: qubes-core-vm = %{version}-%{release}
  146. Obsoletes: qubes-core-vm < 4.0.0
  147. Provides: qubes-core-vm-doc = %{version}-%{release}
  148. Obsoletes: qubes-core-vm-doc < 4.0.0
  149. BuildRequires: pandoc
  150. BuildRequires: xen-devel
  151. BuildRequires: libX11-devel
  152. BuildRequires: qubes-utils-devel >= 3.1.3
  153. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  154. BuildRequires: pam-devel
  155. %description
  156. The Qubes core files for installation inside a Qubes VM.
  157. %package -n python2-dnf-plugins-qubes-hooks
  158. Summary: DNF plugin for Qubes specific post-installation actions
  159. BuildRequires: python2-devel
  160. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  161. %description -n python2-dnf-plugins-qubes-hooks
  162. DNF plugin for Qubes specific post-installation actions:
  163. * notify dom0 that updates were installed
  164. * refresh applications shortcut list
  165. %package -n python3-dnf-plugins-qubes-hooks
  166. Summary: DNF plugin for Qubes specific post-installation actions
  167. BuildRequires: python3-devel
  168. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  169. %description -n python3-dnf-plugins-qubes-hooks
  170. DNF plugin for Qubes specific post-installation actions:
  171. * notify dom0 that updates were installed
  172. * refresh applications shortcut list
  173. %package qrexec
  174. Summary: Qubes qrexec agent
  175. Requires: qubes-core-agent
  176. Requires: nautilus-python
  177. Conflicts: qubes-core-vm < 4.0.0
  178. %description qrexec
  179. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  180. requested by dom0 or other VMs, according to dom0-enforced policy.
  181. %package nautilus
  182. Summary: Qubes integration for Nautilus
  183. Requires: qubes-core-agent
  184. Requires: nautilus-python
  185. Conflicts: qubes-core-vm < 4.0.0
  186. %description nautilus
  187. Nautilus addons for inter-VM file copy/move/open.
  188. %package dom0-updates
  189. Summary: Scripts required to handle dom0 updates
  190. Requires: qubes-core-agent
  191. Requires: fakeroot
  192. Conflicts: qubes-core-vm < 4.0.0
  193. %description dom0-updates
  194. Scripts required to handle dom0 updates.
  195. %package networking
  196. Summary: Networking support for Qubes VM
  197. Requires: ethtool
  198. Requires: net-tools
  199. Requires: nftables
  200. Requires: socat
  201. Requires: qubes-core-agent
  202. Requires: tinyproxy
  203. Conflicts: qubes-core-vm < 4.0.0
  204. %description networking
  205. This package provides:
  206. * basic network functionality (setting IP address, DNS, default gateway)
  207. * proxy service used by TemplateVMs to download updates
  208. * qubes-firewall service (FirewallVM)
  209. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  210. qubes-core-agent-network-manager.
  211. %package network-manager
  212. Summary: NetworkManager integration for Qubes VM
  213. # to show/hide nm-applet
  214. Requires: NetworkManager >= 0.8.1-1
  215. Requires: glib2
  216. Requires: qubes-core-agent-networking
  217. Conflicts: qubes-core-vm < 4.0.0
  218. %description network-manager
  219. Integration of NetworkManager for Qubes VM:
  220. * make connections config persistent
  221. * adjust DNS redirections when needed
  222. * show/hide NetworkManager applet icon
  223. %package passwordless-root
  224. Summary: Passwordless root access from normal user
  225. Conflicts: qubes-core-vm < 4.0.0
  226. %description passwordless-root
  227. Configure sudo, PolicyKit and similar tool to not ask for any password when
  228. switching from user to root. Since all the user data in a VM is accessible
  229. already from normal user account, there is not much more to guard there. Qubes
  230. VM is a single user system.
  231. %define _builddir %(pwd)
  232. %define kde_service_dir /usr/share/kde4/services
  233. %prep
  234. # we operate on the current directory, so no need to unpack anything
  235. # symlink is to generate useful debuginfo packages
  236. rm -f %{name}-%{version}
  237. ln -sf . %{name}-%{version}
  238. %setup -T -D
  239. %build
  240. for dir in qubes-rpc qrexec misc; do
  241. (cd $dir; make)
  242. done
  243. make -C doc manpages
  244. %pre
  245. # Make sure there is a qubes group
  246. groupadd --force --system --gid 98 qubes
  247. id -u 'user' >/dev/null 2>&1 || {
  248. useradd --user-group --create-home --shell /bin/bash user
  249. }
  250. usermod -a --groups qubes user
  251. if [ "$1" != 1 ] ; then
  252. # do this whole %%pre thing only when updating for the first time...
  253. exit 0
  254. fi
  255. mkdir -p /var/lib/qubes
  256. if [ -e /etc/fstab ] ; then
  257. mv /etc/fstab /var/lib/qubes/fstab.orig
  258. fi
  259. usermod -L user
  260. %pre passwordless-root
  261. usermod -p '' root
  262. %install
  263. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  264. make install-vm DESTDIR=$RPM_BUILD_ROOT
  265. %if %{fedora} >= 22
  266. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  267. %endif
  268. %triggerin -- initscripts
  269. if [ -e /etc/init/serial.conf ]; then
  270. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  271. fi
  272. %triggerin -- grub2-tools
  273. if ! grep -q /etc/default/grub.qubes /etc/default/grub 2>/dev/null; then
  274. # do not keep Qubes-related settings directly in user-controlled config,
  275. # include another file
  276. echo '. /etc/default/grub.qubes' >> /etc/default/grub
  277. fi
  278. %post
  279. # disable some Upstart services
  280. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  281. if [ -e /etc/init/$F.conf ]; then
  282. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  283. fi
  284. done
  285. # Remove old firmware updates link
  286. if [ -L /lib/firmware/updates ]; then
  287. rm -f /lib/firmware/updates
  288. fi
  289. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  290. echo >> /etc/yum.conf
  291. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  292. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  293. fi
  294. # And actually setup the proxy usage in package managers
  295. /usr/lib/qubes/update-proxy-configs
  296. # Location of files which contains list of protected files
  297. mkdir -p /etc/qubes/protected-files.d
  298. . /usr/lib/qubes/init/functions
  299. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  300. if ! is_protected_file /etc/hosts ; then
  301. if ! grep -q localhost /etc/hosts; then
  302. cat <<EOF > /etc/hosts
  303. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  304. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  305. EOF
  306. fi
  307. fi
  308. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  309. # in the form expected by qubes-sysinit.sh
  310. if ! is_protected_file /etc/hostname ; then
  311. for ip in '127\.0\.0\.1' '::1'; do
  312. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  313. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  314. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  315. else
  316. echo "${ip} `hostname`" >> /etc/hosts
  317. fi
  318. done
  319. fi
  320. if [ "$1" != 1 ] ; then
  321. # do the rest of %%post thing only when updating for the first time...
  322. exit 0
  323. fi
  324. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  325. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  326. fi
  327. # Remove most of the udev scripts to speed up the VM boot time
  328. # Just leave the xen* scripts, that are needed if this VM was
  329. # ever used as a net backend (e.g. as a VPN domain in the future)
  330. #echo "--> Removing unnecessary udev scripts..."
  331. mkdir -p /var/lib/qubes/removed-udev-scripts
  332. for f in /etc/udev/rules.d/*
  333. do
  334. if [ $(basename $f) == "xen-backend.rules" ] ; then
  335. continue
  336. fi
  337. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  338. continue
  339. fi
  340. if echo $f | grep -q qubes; then
  341. continue
  342. fi
  343. mv $f /var/lib/qubes/removed-udev-scripts/
  344. done
  345. mkdir -p /rw
  346. #rm -f /etc/mtab
  347. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  348. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  349. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  350. %triggerin -- notification-daemon
  351. # Enable autostart of notification-daemon when installed
  352. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  353. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  354. fi
  355. exit 0
  356. %triggerin -- selinux-policy
  357. #echo "--> Disabling SELinux..."
  358. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  359. mv /etc/selinux/config.processed /etc/selinux/config
  360. setenforce 0 2>/dev/null
  361. exit 0
  362. %post network-manager
  363. # Create NetworkManager configuration if we do not have it
  364. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  365. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  366. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  367. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  368. fi
  369. # Remove ip_forward setting from sysctl, so NM will not reset it
  370. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  371. /usr/lib/qubes/qubes-fix-nm-conf.sh
  372. %preun
  373. if [ "$1" = 0 ] ; then
  374. # no more packages left
  375. if [ -e /var/lib/qubes/fstab.orig ] ; then
  376. mv /var/lib/qubes/fstab.orig /etc/fstab
  377. fi
  378. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  379. if [ -e /var/lib/qubes/serial.orig ] ; then
  380. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  381. fi
  382. fi
  383. %postun
  384. if [ $1 -eq 0 ] ; then
  385. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  386. if [ -L /lib/firmware/updates ]; then
  387. rm /lib/firmware/updates
  388. fi
  389. rm -rf /var/lib/qubes/xdg
  390. fi
  391. %postun passwordless-root
  392. if [ $1 -eq 0 ]; then
  393. usermod -p '*' root
  394. fi
  395. %posttrans
  396. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  397. %clean
  398. rm -rf $RPM_BUILD_ROOT
  399. rm -f %{name}-%{version}
  400. %files
  401. %defattr(-,root,root,-)
  402. %dir /var/lib/qubes
  403. %dir /var/run/qubes
  404. %{kde_service_dir}/qvm-copy.desktop
  405. %{kde_service_dir}/qvm-move.desktop
  406. %{kde_service_dir}/qvm-dvm.desktop
  407. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  408. /etc/fstab
  409. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  410. %dir /etc/qubes-rpc
  411. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  412. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  413. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  414. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  415. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  416. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  417. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  418. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  419. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  420. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  421. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  422. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  423. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  424. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  425. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  426. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  427. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  428. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  429. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  430. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  431. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  432. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  433. %config(noreplace) /etc/qubes-rpc/qubes.GetDate
  434. %dir /etc/qubes/autostart
  435. %config(noreplace) /etc/default/grub.qubes
  436. /etc/qubes/autostart/README.txt
  437. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  438. %dir /etc/qubes/suspend-pre.d
  439. /etc/qubes/suspend-pre.d/README
  440. %dir /etc/qubes/suspend-post.d
  441. /etc/qubes/suspend-post.d/README
  442. /etc/qubes/suspend-post.d/qvm-sync-clock.sh
  443. %dir /etc/qubes/post-install.d
  444. /etc/qubes/post-install.d/README
  445. /etc/qubes/post-install.d/*.sh
  446. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  447. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  448. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  449. %config(noreplace) /etc/qubes-suspend-module-blacklist
  450. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  451. %config(noreplace) /etc/yum.repos.d/qubes-r4.repo
  452. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  453. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  454. %if %{fedora} < 22
  455. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  456. %endif
  457. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  458. /usr/sbin/qubes-serial-login
  459. /usr/bin/qvm-copy-to-vm
  460. /usr/bin/qvm-move-to-vm
  461. /usr/bin/qvm-open-in-dvm
  462. /usr/bin/qvm-open-in-vm
  463. /usr/bin/qvm-run-vm
  464. /usr/bin/qvm-features-request
  465. /usr/bin/qvm-sync-clock
  466. /usr/bin/xenstore-watch-qubes
  467. /usr/bin/qubes-desktop-run
  468. /usr/bin/qubes-open
  469. /usr/bin/qubes-session-autostart
  470. %dir /usr/lib/qubes
  471. /usr/lib/qubes/prepare-suspend
  472. /usr/lib/qubes/qfile-agent
  473. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  474. /usr/lib/qubes/qopen-in-vm
  475. /usr/lib/qubes/qrun-in-vm
  476. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  477. /usr/lib/qubes/qvm-copy-to-vm.kde
  478. /usr/lib/qubes/qvm-move-to-vm.kde
  479. /usr/lib/qubes/tar2qfile
  480. /usr/lib/qubes/vm-file-editor
  481. /usr/lib/qubes/close-window
  482. /usr/lib/qubes/xdg-icon
  483. /usr/lib/qubes/update-proxy-configs
  484. /usr/lib/qubes/upgrades-installed-check
  485. /usr/lib/qubes/upgrades-status-notify
  486. /usr/lib/qubes/qubes-sync-clock
  487. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  488. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  489. %dir /usr/lib/qubes/init
  490. /usr/lib/qubes/init/bind-dirs.sh
  491. /usr/lib/qubes/init/control-printer-icon.sh
  492. /usr/lib/qubes/init/functions
  493. /usr/lib/qubes/init/misc-post-stop.sh
  494. /usr/lib/qubes/init/misc-post.sh
  495. /usr/lib/qubes/init/mount-dirs.sh
  496. /usr/lib/qubes/init/qubes-early-vm-config.sh
  497. /usr/lib/qubes/init/qubes-random-seed.sh
  498. /usr/lib/qubes/init/qubes-sysinit.sh
  499. /usr/lib/qubes/init/setup-rw.sh
  500. /usr/lib/qubes/init/setup-rwdev.sh
  501. /usr/lib/qubes/init/functions
  502. %dir /usr/lib/qubes-bind-dirs.d
  503. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  504. /usr/lib/python2.7/site-packages/qubesxdg.py*
  505. /usr/share/qubes/serial.conf
  506. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  507. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  508. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  509. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  510. %{_mandir}/man1/qvm-*.1*
  511. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  512. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  513. %dir %{python_sitelib}/qubesagent
  514. %{python_sitelib}/qubesagent/__init__.py*
  515. %{python_sitelib}/qubesagent/firewall.py*
  516. %{python_sitelib}/qubesagent/test_firewall.py*
  517. /usr/share/qubes/mime-override/globs
  518. /usr/share/qubes/qubes-master-key.asc
  519. %dir /mnt/removable
  520. %dir /rw
  521. %files -n python2-dnf-plugins-qubes-hooks
  522. %{python2_sitelib}/dnf-plugins/*
  523. %files -n python3-dnf-plugins-qubes-hooks
  524. %{python3_sitelib}/dnf-plugins/*
  525. %files qrexec
  526. %config(noreplace) /etc/pam.d/qrexec
  527. /usr/bin/qrexec-fork-server
  528. /usr/bin/qrexec-client-vm
  529. /usr/lib/qubes/qrexec-agent
  530. /usr/lib/qubes/qrexec-client-vm
  531. /usr/lib/qubes/qrexec_client_vm
  532. /usr/lib/qubes/qubes-rpc-multiplexer
  533. /lib/systemd/system/qubes-qrexec-agent.service
  534. %{_mandir}/man1/qrexec-client-vm.1*
  535. %files nautilus
  536. /usr/lib/qubes/qvm-copy-to-vm.gnome
  537. /usr/lib/qubes/qvm-move-to-vm.gnome
  538. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  539. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  540. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  541. %files dom0-updates
  542. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  543. /usr/lib/qubes/qubes-download-dom0-updates.sh
  544. %files networking
  545. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  546. %config(noreplace) /etc/qubes/ip6tables.rules
  547. %config(noreplace) /etc/qubes/iptables.rules
  548. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  549. %config(noreplace) /etc/tinyproxy/updates-blacklist
  550. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  551. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  552. /etc/xen/scripts/vif-qubes-nat.sh
  553. /etc/xen/scripts/vif-route-qubes
  554. /lib/systemd/system/qubes-firewall.service
  555. /lib/systemd/system/qubes-iptables.service
  556. /lib/systemd/system/qubes-network.service
  557. /lib/systemd/system/qubes-updates-proxy.service
  558. /usr/lib/qubes/init/network-proxy-setup.sh
  559. /usr/lib/qubes/init/qubes-iptables
  560. /usr/lib/qubes/iptables-updates-proxy
  561. /usr/lib/qubes/qubes-setup-dnat-to-ns
  562. /usr/lib/qubes/setup-ip
  563. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  564. /usr/sbin/qubes-firewall
  565. %files network-manager
  566. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  567. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  568. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  569. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  570. /usr/lib/qubes/network-manager-prepare-conf-dir
  571. /usr/lib/qubes/qubes-fix-nm-conf.sh
  572. /usr/lib/qubes/show-hide-nm-applet.sh
  573. %files passwordless-root
  574. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  575. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  576. %config(noreplace) /etc/sudoers.d/qubes
  577. %package sysvinit
  578. Summary: Qubes unit files for SysV init style or upstart
  579. License: GPL v2 only
  580. Group: Qubes
  581. Requires: upstart
  582. Requires: qubes-core-agent
  583. Requires: qubes-core-agent-qrexec
  584. Requires: qubes-core-agent-networking
  585. Provides: qubes-core-agent-init-scripts
  586. Conflicts: qubes-core-agent-systemd
  587. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  588. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  589. %description sysvinit
  590. The Qubes core startup configuration for SysV init (or upstart).
  591. %files sysvinit
  592. /etc/init.d/qubes-sysinit
  593. /etc/init.d/qubes-core-early
  594. /etc/init.d/qubes-core
  595. /etc/init.d/qubes-core-netvm
  596. /etc/init.d/qubes-firewall
  597. /etc/init.d/qubes-iptables
  598. /etc/init.d/qubes-updates-proxy
  599. /etc/init.d/qubes-qrexec-agent
  600. /etc/init.d/qubes-updates-proxy-forwarder
  601. /etc/sysconfig/modules/qubes-core.modules
  602. %post sysvinit
  603. #echo "--> Turning off unnecessary services..."
  604. # FIXME: perhaps there is more elegant way to do this?
  605. for f in /etc/init.d/*
  606. do
  607. srv=`basename $f`
  608. [ $srv = 'functions' ] && continue
  609. [ $srv = 'killall' ] && continue
  610. [ $srv = 'halt' ] && continue
  611. [ $srv = 'single' ] && continue
  612. [ $srv = 'reboot' ] && continue
  613. [ $srv = 'qubes-gui' ] && continue
  614. chkconfig $srv off
  615. done
  616. #echo "--> Enabling essential services..."
  617. chkconfig rsyslog on
  618. chkconfig haldaemon on
  619. chkconfig messagebus on
  620. for svc in %qubes_services ; do
  621. if [ "$1" = 1 ] ; then
  622. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  623. else
  624. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  625. fi
  626. done
  627. # dropped services
  628. chkconfig qubes-netwatcher off || :
  629. # TODO: make this not display the silly message about security context...
  630. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  631. %preun sysvinit
  632. if [ "$1" = 0 ] ; then
  633. # no more packages left
  634. for svc in %qubes_services ; do
  635. chkconfig --del $svc
  636. done
  637. fi
  638. %package systemd
  639. Summary: Qubes unit files for SystemD init style
  640. License: GPL v2 only
  641. Group: Qubes
  642. Requires: systemd
  643. Requires(post): systemd-units
  644. Requires(preun): systemd-units
  645. Requires(postun): systemd-units
  646. Requires: qubes-core-agent
  647. Provides: qubes-core-agent-init-scripts
  648. Conflicts: qubes-core-agent-sysvinit
  649. Provides: qubes-core-vm-systemd = %{version}-%{release}
  650. Obsoletes: qubes-core-vm-systemd < 4.0.0
  651. %description systemd
  652. The Qubes core startup configuration for SystemD init.
  653. %files systemd
  654. %defattr(-,root,root,-)
  655. /lib/systemd/system/qubes-misc-post.service
  656. /lib/systemd/system/qubes-mount-dirs.service
  657. /lib/systemd/system/qubes-sysinit.service
  658. /lib/systemd/system/qubes-early-vm-config.service
  659. /lib/systemd/system/qubes-update-check.service
  660. /lib/systemd/system/qubes-update-check.timer
  661. /lib/systemd/system/qubes-sync-time.service
  662. /lib/systemd/system/qubes-sync-time.timer
  663. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  664. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  665. /lib/systemd/system-preset/%qubes_preset_file
  666. /lib/modules-load.d/qubes-core.conf
  667. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  668. /lib/systemd/system/crond.service.d/30_qubes.conf
  669. /lib/systemd/system/cups.service.d/30_qubes.conf
  670. /lib/systemd/system/cups.socket.d/30_qubes.conf
  671. /lib/systemd/system/cups.path.d/30_qubes.conf
  672. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  673. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  674. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  675. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  676. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  677. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  678. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  679. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  680. /lib/systemd/system/systemd-timesyncd.service.d/30_qubes.conf
  681. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  682. /lib/systemd/system/tor.service.d/30_qubes.conf
  683. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  684. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  685. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  686. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  687. %post systemd
  688. changed=
  689. %scriptletfuns
  690. if [ $1 -eq 1 ]
  691. then
  692. preset_units %{_presetdir}/%qubes_preset_file initial
  693. changed=true
  694. else
  695. preset_units %{_presetdir}/%qubes_preset_file upgrade
  696. changed=true
  697. # Upgrade path - now qubes-iptables is used instead
  698. for svc in iptables ip6tables
  699. do
  700. if [ -f "$svc".service ]
  701. then
  702. systemctl --no-reload preset "$svc".service
  703. changed=true
  704. fi
  705. done
  706. fi
  707. if [ $1 -eq 1 ]
  708. then
  709. # First install.
  710. # Set default "runlevel".
  711. # FIXME: this ought to be done via kernel command line.
  712. # The fewer deviations of the template from the seed
  713. # image, the better.
  714. rm -f %{_sysconfdir}/systemd/system/default.target
  715. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  716. changed=true
  717. fi
  718. # remove old symlinks
  719. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  720. then
  721. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  722. changed=true
  723. fi
  724. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  725. then
  726. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  727. changed=true
  728. fi
  729. if [ "x$changed" != "x" ]
  730. then
  731. systemctl daemon-reload
  732. fi
  733. %preun systemd
  734. if [ $1 -eq 0 ] ; then
  735. # Run this only during uninstall.
  736. # Save the preset file to later use it to re-preset services there
  737. # once the Qubes OS preset file is removed.
  738. mkdir -p %{_rundir}/qubes-uninstall
  739. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  740. fi
  741. %postun systemd
  742. changed=
  743. %scriptletfuns
  744. if [ -d %{_rundir}/qubes-uninstall ]
  745. then
  746. # We have a saved preset file (or more).
  747. # Re-preset the units mentioned there.
  748. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  749. rm -rf %{_rundir}/qubes-uninstall
  750. changed=true
  751. fi
  752. if [ "x$changed" != "x" ]
  753. then
  754. systemctl daemon-reload
  755. fi