core-vm.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-vm
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: ntpdate
  123. Requires: net-tools
  124. Requires: qubes-utils >= 3.1.3
  125. Requires: initscripts
  126. Requires: gawk
  127. Requires: sed
  128. # for dispvm-prerun.sh
  129. Requires: procps-ng
  130. Requires: util-linux
  131. # for qubes-desktop-run
  132. Requires: pygobject3-base
  133. Requires: dbus-python
  134. # for qubes-session-autostart, xdg-icon
  135. Requires: pyxdg
  136. Requires: python-daemon
  137. Requires: nftables
  138. Requires: ImageMagick
  139. Requires: librsvg2-tools
  140. Requires: fakeroot
  141. Requires: desktop-notification-daemon
  142. # to show/hide nm-applet
  143. Requires: dconf
  144. Requires: zenity
  145. Requires: qubes-libvchan
  146. Requires: qubes-db-vm
  147. %if 0%{fedora} >= 23
  148. Requires: python3-dnf-plugins-qubes-hooks
  149. %else
  150. Requires: python2-dnf-plugins-qubes-hooks
  151. %endif
  152. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  153. Obsoletes: qubes-upgrade-vm < 3.2
  154. BuildRequires: xen-devel
  155. BuildRequires: libX11-devel
  156. BuildRequires: qubes-utils-devel >= 3.1.3
  157. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  158. %package -n python2-dnf-plugins-qubes-hooks
  159. Summary: DNF plugin for Qubes specific post-installation actions
  160. BuildRequires: python2-devel
  161. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  162. %description -n python2-dnf-plugins-qubes-hooks
  163. DNF plugin for Qubes specific post-installation actions:
  164. * notify dom0 that updates were installed
  165. * refresh applications shortcut list
  166. %package -n python3-dnf-plugins-qubes-hooks
  167. Summary: DNF plugin for Qubes specific post-installation actions
  168. BuildRequires: python3-devel
  169. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  170. %description -n python3-dnf-plugins-qubes-hooks
  171. DNF plugin for Qubes specific post-installation actions:
  172. * notify dom0 that updates were installed
  173. * refresh applications shortcut list
  174. %package -n qubes-nautilus
  175. Summary: Qubes integration for Nautilus
  176. Requires: qubes-core-vm
  177. Requires: nautilus-python
  178. %description -n qubes-nautilus
  179. Nautilus addons for inter-VM file copy/move/open.
  180. %define _builddir %(pwd)
  181. %define kde_service_dir /usr/share/kde4/services
  182. %description
  183. The Qubes core files for installation inside a Qubes VM.
  184. %prep
  185. # we operate on the current directory, so no need to unpack anything
  186. # symlink is to generate useful debuginfo packages
  187. rm -f %{name}-%{version}
  188. ln -sf . %{name}-%{version}
  189. %setup -T -D
  190. %build
  191. for dir in qubes-rpc qrexec misc; do
  192. (cd $dir; make)
  193. done
  194. %pre
  195. # Make sure there is a qubes group
  196. groupadd --force --system --gid 98 qubes
  197. id -u 'user' >/dev/null 2>&1 || {
  198. useradd --user-group --create-home --shell /bin/bash user
  199. }
  200. usermod -a --groups qubes user
  201. if [ "$1" != 1 ] ; then
  202. # do this whole %%pre thing only when updating for the first time...
  203. exit 0
  204. fi
  205. mkdir -p /var/lib/qubes
  206. if [ -e /etc/fstab ] ; then
  207. mv /etc/fstab /var/lib/qubes/fstab.orig
  208. fi
  209. usermod -p '' root
  210. usermod -L user
  211. %install
  212. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  213. make install-vm DESTDIR=$RPM_BUILD_ROOT
  214. %if %{fedora} >= 22
  215. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  216. %endif
  217. %triggerin -- initscripts
  218. if [ -e /etc/init/serial.conf ]; then
  219. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  220. fi
  221. %post
  222. # disable some Upstart services
  223. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  224. if [ -e /etc/init/$F.conf ]; then
  225. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  226. fi
  227. done
  228. # Create NetworkManager configuration if we do not have it
  229. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  230. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  231. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  232. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  233. fi
  234. /usr/lib/qubes/qubes-fix-nm-conf.sh
  235. # Remove ip_forward setting from sysctl, so NM will not reset it
  236. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  237. # Remove old firmware updates link
  238. if [ -L /lib/firmware/updates ]; then
  239. rm -f /lib/firmware/updates
  240. fi
  241. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  242. echo >> /etc/yum.conf
  243. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  244. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  245. fi
  246. # And actually setup the proxy usage in package managers
  247. /usr/lib/qubes/update-proxy-configs
  248. # Location of files which contains list of protected files
  249. mkdir -p /etc/qubes/protected-files.d
  250. . /usr/lib/qubes/init/functions
  251. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  252. if ! is_protected_file /etc/hosts ; then
  253. if ! grep -q localhost /etc/hosts; then
  254. cat <<EOF > /etc/hosts
  255. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  256. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  257. EOF
  258. fi
  259. fi
  260. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  261. # in the form expected by qubes-sysinit.sh
  262. if ! is_protected_file /etc/hostname ; then
  263. for ip in '127\.0\.0\.1' '::1'; do
  264. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  265. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  266. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  267. else
  268. echo "${ip} `hostname`" >> /etc/hosts
  269. fi
  270. done
  271. fi
  272. %if %{fedora} >= 20
  273. # Make sure there is a default locale set so gnome-terminal will start
  274. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  275. touch /etc/locale.conf
  276. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  277. fi
  278. # ... and make sure it is really generated
  279. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  280. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  281. base=`echo "$current_locale" | cut -f 1 -d .`
  282. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  283. [ -n "$charmap" ] && charmap="-f $charmap"
  284. localedef -i $base $charmap $current_locale
  285. fi
  286. %endif
  287. if [ "$1" != 1 ] ; then
  288. # do the rest of %%post thing only when updating for the first time...
  289. exit 0
  290. fi
  291. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  292. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  293. fi
  294. # Remove most of the udev scripts to speed up the VM boot time
  295. # Just leave the xen* scripts, that are needed if this VM was
  296. # ever used as a net backend (e.g. as a VPN domain in the future)
  297. #echo "--> Removing unnecessary udev scripts..."
  298. mkdir -p /var/lib/qubes/removed-udev-scripts
  299. for f in /etc/udev/rules.d/*
  300. do
  301. if [ $(basename $f) == "xen-backend.rules" ] ; then
  302. continue
  303. fi
  304. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  305. continue
  306. fi
  307. if echo $f | grep -q qubes; then
  308. continue
  309. fi
  310. mv $f /var/lib/qubes/removed-udev-scripts/
  311. done
  312. mkdir -p /rw
  313. #rm -f /etc/mtab
  314. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  315. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  316. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  317. %triggerin -- notification-daemon
  318. # Enable autostart of notification-daemon when installed
  319. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  320. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  321. fi
  322. exit 0
  323. %triggerin -- selinux-policy
  324. #echo "--> Disabling SELinux..."
  325. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  326. mv /etc/selinux/config.processed /etc/selinux/config
  327. setenforce 0 2>/dev/null
  328. exit 0
  329. %preun
  330. if [ "$1" = 0 ] ; then
  331. # no more packages left
  332. if [ -e /var/lib/qubes/fstab.orig ] ; then
  333. mv /var/lib/qubes/fstab.orig /etc/fstab
  334. fi
  335. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  336. if [ -e /var/lib/qubes/serial.orig ] ; then
  337. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  338. fi
  339. fi
  340. %postun
  341. if [ $1 -eq 0 ] ; then
  342. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  343. if [ -L /lib/firmware/updates ]; then
  344. rm /lib/firmware/updates
  345. fi
  346. rm -rf /var/lib/qubes/xdg
  347. fi
  348. %posttrans
  349. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  350. %clean
  351. rm -rf $RPM_BUILD_ROOT
  352. rm -f %{name}-%{version}
  353. %files
  354. %defattr(-,root,root,-)
  355. %dir /var/lib/qubes
  356. %dir /var/run/qubes
  357. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  358. %{kde_service_dir}/qvm-copy.desktop
  359. %{kde_service_dir}/qvm-move.desktop
  360. %{kde_service_dir}/qvm-dvm.desktop
  361. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  362. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  363. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  364. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  365. /etc/fstab
  366. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  367. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  368. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  369. %dir /etc/qubes-rpc
  370. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  371. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  372. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  373. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  374. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  375. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  376. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  377. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  378. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  379. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  380. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  381. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  382. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  383. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  384. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  385. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  386. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  387. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  388. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  389. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  390. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  391. %dir /etc/qubes/autostart
  392. /etc/qubes/autostart/README.txt
  393. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  394. %dir /etc/qubes/suspend-pre.d
  395. /etc/qubes/suspend-pre.d/README
  396. %dir /etc/qubes/suspend-post.d
  397. /etc/qubes/suspend-post.d/README
  398. %config(noreplace) /etc/sudoers.d/qubes
  399. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  400. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  401. %config(noreplace) /etc/qubes/iptables.rules
  402. %config(noreplace) /etc/qubes/ip6tables.rules
  403. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  404. %config(noreplace) /etc/tinyproxy/updates-blacklist
  405. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  406. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  407. %config(noreplace) /etc/qubes-suspend-module-blacklist
  408. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  409. /etc/xen/scripts/vif-route-qubes
  410. /etc/xen/scripts/vif-qubes-nat.sh
  411. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  412. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  413. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  414. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  415. %if %{fedora} < 22
  416. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  417. %endif
  418. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  419. /usr/sbin/qubes-serial-login
  420. /usr/bin/qvm-copy-to-vm
  421. /usr/bin/qvm-move-to-vm
  422. /usr/bin/qvm-open-in-dvm
  423. /usr/bin/qvm-open-in-vm
  424. /usr/bin/qvm-run-vm
  425. /usr/bin/qvm-features-request
  426. /usr/bin/xenstore-watch-qubes
  427. /usr/bin/qubes-desktop-run
  428. /usr/bin/qubes-open
  429. /usr/bin/qrexec-fork-server
  430. /usr/bin/qrexec-client-vm
  431. /usr/bin/qubes-session-autostart
  432. %dir /usr/lib/qubes
  433. /usr/lib/qubes/vusb-ctl.py*
  434. /usr/lib/qubes/dispvm-prerun.sh
  435. /usr/lib/qubes/sync-ntp-clock
  436. /usr/lib/qubes/prepare-suspend
  437. /usr/lib/qubes/network-manager-prepare-conf-dir
  438. /usr/lib/qubes/show-hide-nm-applet.sh
  439. /usr/lib/qubes/qrexec-agent
  440. /usr/lib/qubes/qrexec-client-vm
  441. /usr/lib/qubes/qrexec_client_vm
  442. /usr/lib/qubes/qubes-rpc-multiplexer
  443. /usr/lib/qubes/qfile-agent
  444. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  445. /usr/lib/qubes/qopen-in-vm
  446. /usr/lib/qubes/qrun-in-vm
  447. /usr/lib/qubes/qubes-download-dom0-updates.sh
  448. /usr/lib/qubes/qubes-fix-nm-conf.sh
  449. /usr/lib/qubes/qubes-setup-dnat-to-ns
  450. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  451. /usr/lib/qubes/qvm-copy-to-vm.kde
  452. /usr/lib/qubes/qvm-move-to-vm.kde
  453. /usr/lib/qubes/setup-ip
  454. /usr/lib/qubes/tar2qfile
  455. /usr/lib/qubes/vm-file-editor
  456. /usr/lib/qubes/iptables-updates-proxy
  457. /usr/lib/qubes/close-window
  458. /usr/lib/qubes/xdg-icon
  459. /usr/lib/qubes/update-proxy-configs
  460. /usr/lib/qubes/upgrades-installed-check
  461. /usr/lib/qubes/upgrades-status-notify
  462. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  463. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  464. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  465. %dir /usr/lib/qubes/init
  466. /usr/lib/qubes/init/*.sh
  467. /usr/lib/qubes/init/functions
  468. %dir /usr/lib/qubes-bind-dirs.d
  469. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  470. /usr/lib/python2.7/site-packages/qubesxdg.py*
  471. /usr/sbin/qubes-firewall
  472. /usr/share/qubes/serial.conf
  473. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  474. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  475. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  476. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  477. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  478. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  479. %dir %{python_sitelib}/qubesagent
  480. %{python_sitelib}/qubesagent/__init__.py*
  481. %{python_sitelib}/qubesagent/firewall.py*
  482. %{python_sitelib}/qubesagent/test_firewall.py*
  483. /usr/share/qubes/mime-override/globs
  484. /usr/share/qubes/qubes-master-key.asc
  485. %dir /home_volatile
  486. %attr(700,user,user) /home_volatile/user
  487. %dir /mnt/removable
  488. %dir /rw
  489. %files -n python2-dnf-plugins-qubes-hooks
  490. %{python2_sitelib}/dnf-plugins/*
  491. %files -n python3-dnf-plugins-qubes-hooks
  492. %{python3_sitelib}/dnf-plugins/*
  493. %files -n qubes-nautilus
  494. /usr/lib/qubes/qvm-copy-to-vm.gnome
  495. /usr/lib/qubes/qvm-move-to-vm.gnome
  496. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  497. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  498. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  499. %package sysvinit
  500. Summary: Qubes unit files for SysV init style or upstart
  501. License: GPL v2 only
  502. Group: Qubes
  503. Requires: upstart
  504. Requires: qubes-core-vm
  505. Provides: qubes-core-vm-init-scripts
  506. Conflicts: qubes-core-vm-systemd
  507. %description sysvinit
  508. The Qubes core startup configuration for SysV init (or upstart).
  509. %files sysvinit
  510. /etc/init.d/qubes-sysinit
  511. /etc/init.d/qubes-core-early
  512. /etc/init.d/qubes-core
  513. /etc/init.d/qubes-dvm
  514. /etc/init.d/qubes-core-netvm
  515. /etc/init.d/qubes-firewall
  516. /etc/init.d/qubes-iptables
  517. /etc/init.d/qubes-updates-proxy
  518. /etc/init.d/qubes-qrexec-agent
  519. /etc/sysconfig/modules/qubes-core.modules
  520. /etc/sysconfig/modules/qubes-misc.modules
  521. %post sysvinit
  522. #echo "--> Turning off unnecessary services..."
  523. # FIXME: perhaps there is more elegant way to do this?
  524. for f in /etc/init.d/*
  525. do
  526. srv=`basename $f`
  527. [ $srv = 'functions' ] && continue
  528. [ $srv = 'killall' ] && continue
  529. [ $srv = 'halt' ] && continue
  530. [ $srv = 'single' ] && continue
  531. [ $srv = 'reboot' ] && continue
  532. [ $srv = 'qubes-gui' ] && continue
  533. chkconfig $srv off
  534. done
  535. #echo "--> Enabling essential services..."
  536. chkconfig rsyslog on
  537. chkconfig haldaemon on
  538. chkconfig messagebus on
  539. for svc in %qubes_services ; do
  540. if [ "$1" = 1 ] ; then
  541. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  542. else
  543. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  544. fi
  545. done
  546. # dropped services
  547. chkconfig qubes-netwatcher off || :
  548. # TODO: make this not display the silly message about security context...
  549. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  550. %preun sysvinit
  551. if [ "$1" = 0 ] ; then
  552. # no more packages left
  553. for svc in %qubes_services ; do
  554. chkconfig --del $svc
  555. done
  556. fi
  557. %package systemd
  558. Summary: Qubes unit files for SystemD init style
  559. License: GPL v2 only
  560. Group: Qubes
  561. Requires: systemd
  562. Requires(post): systemd-units
  563. Requires(preun): systemd-units
  564. Requires(postun): systemd-units
  565. Requires: qubes-core-vm
  566. Provides: qubes-core-vm-init-scripts
  567. Conflicts: qubes-core-vm-sysvinit
  568. %description systemd
  569. The Qubes core startup configuration for SystemD init.
  570. %files systemd
  571. %defattr(-,root,root,-)
  572. /lib/systemd/system/qubes-dvm.service
  573. /lib/systemd/system/qubes-misc-post.service
  574. /lib/systemd/system/qubes-firewall.service
  575. /lib/systemd/system/qubes-mount-dirs.service
  576. /lib/systemd/system/qubes-network.service
  577. /lib/systemd/system/qubes-iptables.service
  578. /lib/systemd/system/qubes-sysinit.service
  579. /lib/systemd/system/qubes-early-vm-config.service
  580. /lib/systemd/system/qubes-update-check.service
  581. /lib/systemd/system/qubes-update-check.timer
  582. /lib/systemd/system/qubes-updates-proxy.service
  583. /lib/systemd/system/qubes-qrexec-agent.service
  584. /lib/systemd/system-preset/%qubes_preset_file
  585. /lib/modules-load.d/qubes-core.conf
  586. /lib/modules-load.d/qubes-misc.conf
  587. /usr/lib/qubes/init/qubes-iptables
  588. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  589. /lib/systemd/system/crond.service.d/30_qubes.conf
  590. /lib/systemd/system/cups.service.d/30_qubes.conf
  591. /lib/systemd/system/cups.socket.d/30_qubes.conf
  592. /lib/systemd/system/cups.path.d/30_qubes.conf
  593. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  594. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  595. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  596. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  597. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  598. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  599. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  600. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  601. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  602. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  603. /lib/systemd/system/tor.service.d/30_qubes.conf
  604. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  605. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  606. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  607. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  608. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  609. %post systemd
  610. changed=
  611. %scriptletfuns
  612. if [ $1 -eq 1 ]
  613. then
  614. preset_units %{_presetdir}/%qubes_preset_file initial
  615. changed=true
  616. else
  617. preset_units %{_presetdir}/%qubes_preset_file upgrade
  618. changed=true
  619. # Upgrade path - now qubes-iptables is used instead
  620. for svc in iptables ip6tables
  621. do
  622. if [ -f "$svc".service ]
  623. then
  624. systemctl --no-reload preset "$svc".service
  625. changed=true
  626. fi
  627. done
  628. fi
  629. if [ $1 -eq 1 ]
  630. then
  631. # First install.
  632. # Set default "runlevel".
  633. # FIXME: this ought to be done via kernel command line.
  634. # The fewer deviations of the template from the seed
  635. # image, the better.
  636. rm -f %{_sysconfdir}/systemd/system/default.target
  637. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  638. changed=true
  639. fi
  640. # remove old symlinks
  641. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  642. then
  643. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  644. changed=true
  645. fi
  646. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  647. then
  648. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  649. changed=true
  650. fi
  651. if [ "x$changed" != "x" ]
  652. then
  653. systemctl daemon-reload
  654. fi
  655. %preun systemd
  656. if [ $1 -eq 0 ] ; then
  657. # Run this only during uninstall.
  658. # Save the preset file to later use it to re-preset services there
  659. # once the Qubes OS preset file is removed.
  660. mkdir -p %{_rundir}/qubes-uninstall
  661. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  662. fi
  663. %postun systemd
  664. changed=
  665. %scriptletfuns
  666. if [ -d %{_rundir}/qubes-uninstall ]
  667. then
  668. # We have a saved preset file (or more).
  669. # Re-preset the units mentioned there.
  670. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  671. rm -rf %{_rundir}/qubes-uninstall
  672. changed=true
  673. fi
  674. if [ "x$changed" != "x" ]
  675. then
  676. systemctl daemon-reload
  677. fi