PKGBUILD-keyring.install 448 B

123456789101112131415161718
  1. post_upgrade() {
  2. if usr/bin/pacman-key -l >/dev/null 2>&1; then
  3. usr/bin/pacman-key --populate qubesos-vm
  4. fi
  5. release=$(echo "$1" | cut -d '.' -f 1,2)
  6. if ! [ -h /etc/pacman.d/99-qubes-repository-${release}.conf ] ; then
  7. ln -s /etc/pacman.d/99-qubes-repository-${release}.conf.disabled /etc/pacman.d/99-qubes-repository-${release}.conf
  8. fi
  9. }
  10. post_install() {
  11. if [ -x usr/bin/pacman-key ]; then
  12. post_upgrade "$1"
  13. fi
  14. }