PKGBUILD.install 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434
  1. #!/bin/bash
  2. qubes_preset_file="75-qubes-vm.preset"
  3. ###########################
  4. ## Pre-Install functions ##
  5. ###########################
  6. update_default_user() {
  7. # Make sure there is a qubes group
  8. groupadd --force --system --gid 98 qubes
  9. # Archlinux bash version has a 'bug' when running su -c, /etc/profile is not loaded because bash consider there is no interactive pty when running 'su - user -c' or something like this.
  10. # See https://bugs.archlinux.org/task/31831
  11. id -u 'user' >/dev/null 2>&1 || {
  12. useradd --user-group --create-home --shell /bin/bash user
  13. }
  14. usermod -a --groups qubes user
  15. }
  16. ## arg 1: the new package version
  17. pre_install() {
  18. echo "Pre install..."
  19. update_default_user
  20. # do this whole %pre thing only when updating for the first time...
  21. mkdir -p /var/lib/qubes
  22. # Backup fstab / But use archlinux defaults (cp instead of mv)
  23. if [ -e /etc/fstab ] ; then
  24. cp /etc/fstab /var/lib/qubes/fstab.orig
  25. fi
  26. # Add qubes core related fstab entries
  27. echo "xen /proc/xen xenfs defaults 0 0" >> /etc/fstab
  28. usermod -L root
  29. usermod -L user
  30. }
  31. ## arg 1: the new package version
  32. ## arg 2: the old package version
  33. pre_upgrade() {
  34. # do something here
  35. echo "Pre upgrade..."
  36. update_default_user
  37. }
  38. ###################
  39. ## Install Hooks ##
  40. ###################
  41. configure_notification-daemon() {
  42. # Enable autostart of notification-daemon when installed
  43. if [ ! -L /etc/xdg/autostart/notification-daemon.desktop ]; then
  44. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  45. fi
  46. }
  47. configure_selinux() {
  48. # SELinux is not enabled on archlinux
  49. #echo "--> Disabling SELinux..."
  50. echo "SELINUX not enabled on archlinux. skipped."
  51. # sed -e s/^SELINUX=.*$/SELINUX=disabled/ -i /etc/selinux/config
  52. # setenforce 0 2>/dev/null
  53. }
  54. ############################
  55. ## Post-Install functions ##
  56. ############################
  57. update_qubesconfig() {
  58. # Remove old firmware updates link
  59. if [ -L /lib/firmware/updates ]; then
  60. rm -f /lib/firmware/updates
  61. fi
  62. # convert /usr/local symlink to a mount point
  63. if [ -L /usr/local ]; then
  64. rm -f /usr/local
  65. mkdir /usr/local
  66. mount /usr/local || :
  67. fi
  68. # Fix fstab update to core-agent-linux 4.0.33
  69. grep -F -q "/rw/usrlocal" /etc/fstab || sed "/\/rw\/home/a\/rw\/usrlocal \/usr\/local none noauto,bind,defaults 0 0" -i /etc/fstab
  70. #/usr/lib/qubes/update-proxy-configs
  71. # Archlinux pacman configuration is handled in update_finalize
  72. if ! [ -r /etc/dconf/profile/user ]; then
  73. mkdir -p /etc/dconf/profile
  74. echo "user-db:user" >> /etc/dconf/profile/user
  75. echo "system-db:local" >> /etc/dconf/profile/user
  76. fi
  77. dconf update &> /dev/null || :
  78. # Location of files which contains list of protected files
  79. mkdir -p /etc/qubes/protected-files.d
  80. # shellcheck source=init/functions
  81. . /usr/lib/qubes/init/functions
  82. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  83. if ! is_protected_file /etc/hosts ; then
  84. if ! grep -q localhost /etc/hosts; then
  85. cat <<EOF > /etc/hosts
  86. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 $(hostname)
  87. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  88. EOF
  89. fi
  90. fi
  91. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  92. # in the form expected by qubes-sysinit.sh
  93. if ! is_protected_file /etc/hostname ; then
  94. for ip in '127\.0\.0\.1' '::1'; do
  95. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  96. sed -i "/^${ip}\s/,+0s/\(\s$(hostname)\)\+\(\s\|$\)/\2/g" /etc/hosts
  97. sed -i "s/^${ip}\(\s\|$\).*$/\0 $(hostname)/" /etc/hosts
  98. else
  99. echo "${ip} $(hostname)" >> /etc/hosts
  100. fi
  101. done
  102. fi
  103. }
  104. ############################
  105. ## Service Management Functions ##
  106. ############################
  107. is_static() {
  108. [ -f "/usr/lib/systemd/system/$1" ] && ! grep -q '^[[].nstall]' "/usr/lib/systemd/system/$1"
  109. }
  110. is_masked() {
  111. if [ ! -L /etc/systemd/system/"$1" ]
  112. then
  113. return 1
  114. fi
  115. target=$(readlink /etc/systemd/system/"$1" 2>/dev/null) || :
  116. if [ "$target" = "/dev/null" ]
  117. then
  118. return 0
  119. fi
  120. return 1
  121. }
  122. mask() {
  123. ln -sf /dev/null /etc/systemd/system/"$1"
  124. }
  125. unmask() {
  126. if ! is_masked "$1"
  127. then
  128. return 0
  129. fi
  130. rm -f /etc/systemd/system/"$1"
  131. }
  132. preset_units() {
  133. local represet=
  134. while read -r action unit_name
  135. do
  136. if [ "$action" = "#" ] && [ "$unit_name" = "Units below this line will be re-preset on package upgrade" ]
  137. then
  138. represet=1
  139. continue
  140. fi
  141. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue
  142. [[ -n "$action" && -n "$unit_name" ]] || continue
  143. if [ "$2" = "initial" ] || [ "$represet" = "1" ]
  144. then
  145. if [ "$action" = "disable" ] && is_static "$unit_name"
  146. then
  147. if ! is_masked "$unit_name"
  148. then
  149. # We must effectively mask these units, even if they are static.
  150. mask "$unit_name"
  151. fi
  152. elif [ "$action" = "enable" ] && is_static "$unit_name"
  153. then
  154. if is_masked "$unit_name"
  155. then
  156. # We masked this static unit before, now we unmask it.
  157. unmask "$unit_name"
  158. fi
  159. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  160. else
  161. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  162. fi
  163. fi
  164. done < "$1"
  165. }
  166. restore_units() {
  167. grep '^[[:space:]]*[^#;]' "$1" | while read -r action unit_name
  168. do
  169. if is_static "$unit_name" && is_masked "$unit_name"
  170. then
  171. # If the unit had been masked by us, we must unmask it here.
  172. # Otherwise systemctl preset will fail badly.
  173. unmask "$unit_name"
  174. fi
  175. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  176. done
  177. }
  178. configure_systemd() {
  179. if [ "$1" -eq 1 ]
  180. then
  181. preset_units /usr/lib/systemd/system-preset/$qubes_preset_file initial
  182. changed=true
  183. else
  184. preset_units /usr/lib/systemd/system-preset/$qubes_preset_file upgrade
  185. changed=true
  186. # Upgrade path - now qubes-iptables is used instead
  187. for svc in iptables ip6tables
  188. do
  189. if [ -f "$svc".service ]
  190. then
  191. systemctl --no-reload preset "$svc".service
  192. changed=true
  193. fi
  194. done
  195. fi
  196. if [ "$1" -eq 1 ]
  197. then
  198. # First install.
  199. # Set default "runlevel".
  200. # FIXME: this ought to be done via kernel command line.
  201. # The fewer deviations of the template from the seed
  202. # image, the better.
  203. rm -f /etc/systemd/system/default.target
  204. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  205. changed=true
  206. fi
  207. # remove old symlinks
  208. if [ -L /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  209. then
  210. rm -f /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service
  211. changed=true
  212. fi
  213. if [ -L /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  214. then
  215. rm -f /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service
  216. changed=true
  217. fi
  218. # fix / ro mounted
  219. ln -sf /usr/lib/systemd/system/systemd-remount-fs.service /etc/systemd/system/sysinit.target.wants/
  220. if [ "x$changed" != "x" ]
  221. then
  222. systemctl daemon-reload
  223. fi
  224. }
  225. ######################
  226. ## Archlinux Specific Functions ##
  227. ######################
  228. config_prependtomark() {
  229. FILE=$1
  230. APPENDBEFORELINE=$2
  231. APPENDLINE=$3
  232. grep -F -q "$APPENDLINE" "$FILE" || sed "/$APPENDBEFORELINE/i$APPENDLINE" -i "$FILE"
  233. }
  234. config_appendtomark() {
  235. FILE=$1
  236. APPENDAFTERLINE=$2
  237. APPENDLINE=$3
  238. grep -F -q "$APPENDLINE" "$FILE" || sed "/$APPENDAFTERLINE/a$APPENDLINE" -i "$FILE"
  239. }
  240. config_cleanupmark() {
  241. FILE="$1"
  242. BEGINMARK="$2"
  243. ENDMARK="$3"
  244. if grep -F -q "$BEGINMARK" "$FILE"; then
  245. if grep -F -q "$ENDMARK" "$FILE"; then
  246. cp "$FILE" "$FILE.qubes-update-orig"
  247. sed -i -e "/^$BEGINMARK$/,/^$ENDMARK$/{
  248. /^$ENDMARK$/b
  249. /^$BEGINMARK$/!d
  250. }" "$FILE"
  251. rm -f "$FILE.qubes-update-orig"
  252. else
  253. echo "ERROR: found $BEGINMARK marker but not $ENDMARK in $FILE. Please cleanup this file manually."
  254. fi
  255. elif grep -F -q "$ENDMARK" "$FILE"; then
  256. echo "ERROR: found $ENDMARK marker but not $BEGINMARK in $FILE. Please cleanup this file manually."
  257. fi
  258. }
  259. update_finalize() {
  260. # Archlinux specific: If marker exists, cleanup text between begin and end marker
  261. QUBES_MARKER="### QUBES CONFIG MARKER ###"
  262. if grep -F -q "$QUBES_MARKER" /etc/pacman.conf; then
  263. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "### QUBES CONFIG END MARKER ###"
  264. config_cleanupmark "/etc/pacman.conf" "$QUBES_MARKER" "### QUBES CONFIG END MARKER ###"
  265. # Else, add qubes config block marker
  266. else
  267. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "$QUBES_MARKER"
  268. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "### QUBES CONFIG END MARKER ###"
  269. fi
  270. # Include /etc/pacman.d drop-in directory
  271. config_appendtomark "/etc/pacman.conf" "$QUBES_MARKER" "Include = /etc/pacman.d/*.conf"
  272. /usr/lib/qubes/update-proxy-configs
  273. # Archlinux specific: ensure tty1 is enabled
  274. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  275. systemctl enable getty\@tty1.service
  276. systemctl daemon-reload
  277. }
  278. ## arg 1: the new package version
  279. post_install() {
  280. update_qubesconfig
  281. # do the rest of %post thing only when updating for the first time...
  282. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  283. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  284. fi
  285. chgrp user /var/lib/qubes/dom0-updates
  286. # Remove most of the udev scripts to speed up the VM boot time
  287. # Just leave the xen* scripts, that are needed if this VM was
  288. # ever used as a net backend (e.g. as a VPN domain in the future)
  289. #echo "--> Removing unnecessary udev scripts..."
  290. mkdir -p /var/lib/qubes/removed-udev-scripts
  291. for f in /etc/udev/rules.d/*
  292. do
  293. if [ "$(basename "$f")" == "xen-backend.rules" ] ; then
  294. continue
  295. fi
  296. if echo "$f" | grep -q qubes; then
  297. continue
  298. fi
  299. mv "$f" /var/lib/qubes/removed-udev-scripts/
  300. done
  301. mkdir -p /rw
  302. configure_notification-daemon
  303. configure_selinux
  304. configure_systemd 0
  305. update_finalize
  306. }
  307. ## arg 1: the new package version
  308. ## arg 2: the old package version
  309. post_upgrade() {
  310. update_qubesconfig
  311. configure_notification-daemon
  312. configure_selinux
  313. configure_systemd 1
  314. update_finalize
  315. }
  316. ######################
  317. ## Remove functions ##
  318. ######################
  319. ## arg 1: the old package version
  320. pre_remove() {
  321. # no more packages left
  322. if [ -e /var/lib/qubes/fstab.orig ] ; then
  323. mv /var/lib/qubes/fstab.orig /etc/fstab
  324. fi
  325. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  326. if [ -e /var/lib/qubes/serial.orig ] ; then
  327. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  328. fi
  329. if [ "$1" -eq 0 ] ; then
  330. # Run this only during uninstall.
  331. # Save the preset file to later use it to re-preset services there
  332. # once the Qubes OS preset file is removed.
  333. mkdir -p /run/qubes-uninstall
  334. cp -f /usr/lib/systemd/system-preset/$qubes_preset_file /run/qubes-uninstall/
  335. cp -f /usr/lib/systemd/system-preset/$qubes_preset_file /run/qubes-uninstall/
  336. fi
  337. }
  338. ## arg 1: the old package version
  339. post_remove() {
  340. changed=
  341. if [ -d /run/qubes-uninstall ]
  342. then
  343. # We have a saved preset file (or more).
  344. # Re-preset the units mentioned there.
  345. restore_units /run/qubes-uninstall/$qubes_preset_file
  346. rm -rf /run/qubes-uninstall
  347. changed=true
  348. fi
  349. if [ "x$changed" != "x" ]
  350. then
  351. systemctl daemon-reload
  352. fi
  353. if [ -L /lib/firmware/updates ] ; then
  354. rm /lib/firmware/updates
  355. fi
  356. rm -rf /var/lib/qubes/xdg
  357. for srv in qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-qrexec-agent; do
  358. systemctl disable $srv.service
  359. done
  360. }