rules 921 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Use already defined upstream version as DEB_VERSION_UPSTREAM.
  4. include /usr/share/dpkg/pkg-info.mk
  5. export DH_VERBOSE=1
  6. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  7. %:
  8. dh $@ --with autoreconf
  9. override_dh_auto_configure:
  10. dh_auto_configure -- \
  11. --with-htpasswd=no \
  12. --with-mplayer=/usr/bin/mplayer \
  13. --with-mpv=/usr/bin/mpv \
  14. --with-pam \
  15. --with-pam-service-name=common-auth \
  16. --with-pamtester=no \
  17. --with-xcomposite \
  18. --with-xf86misc=no \
  19. --with-xfixes \
  20. --with-xft \
  21. --with-xkb \
  22. --with-xrandr \
  23. --with-xscreensaver=/usr/lib/xscreensaver \
  24. --with-xss \
  25. --with-xsync
  26. override_dh_auto_build:
  27. GIT_VERSION="$(DEB_VERSION_UPSTREAM)" dh_auto_build
  28. override_dh_autoreconf:
  29. dh_autoreconf ./autogen.sh
  30. override_dh_auto_install:
  31. dh_auto_install
  32. find ./debian -type f -name "LICENSE" -delete
  33. override_dh_auto_clean:
  34. dh_auto_clean
  35. -rm version.c