123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162 |
- qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
- * backup: fix restoring template VMs
- * tools: clarify that qvm-backup needs absolute path
- * backup: fix name of meminfo-writer feature
- * backup: update DispVM template property: template_for_dispvms
- * backup: improve restoring HVMs from Qubes 3.2
- * backup: do not try to read tar's stderr past EOF
- * tests: multi-part volume in backup tests
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
- qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * Implement "blind mode" to avoid listing objects
- * events: ignore events from non-existing domains
- * tools: fix qvm-run --help
- * Always use QubesVM objects, instead of AppVM/TemplateVM etc
- * Move vm.appvms to QubesVM
- * Drop individual VM classes as python types completely
- * tools: finish 'qvm-volume revert' implementation, add tests
- * tools/qvm-start: fix starting a VM with cdrom image
- * vm: drop suspend and resume methods - not part of the Admin API
- * rpm: add conflict with too-old qubes-manager
- [ Mindy Preston ]
- * qvm-start: exit if domain running and no --skip-if-running
- [ Marek Marczykowski-Górecki ]
- * tools: adjust qvm-start message and logic, update tests
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
- qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
- is given
- * vm/dispvm: fix dispvm.cleanup() when no service was called
- * tests: add DispVM tests
- * Improve QubesDaemonNoResponseError error message
- * tools: drop --delete and --unset aliases for --default option
- * doc: update list of properties in qvm-prefs/qubes-prefs man pages
- * doc: add short description of VM classes to qvm-create man page
- * tools: implement qvm-create --root-move-from/--root-copy-from
- * tools: add qvm-create --help-classes
- * backup/restore: make backup header extraction faster
- * backup/restore: do not fail the whole restore when qvm-appmenus is
- missing
- [ blackpit ]
- * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
- [ Marek Marczykowski-Górecki ]
- * tools: fix too long lines
- * tools: cleanup temporary files after qvm-template-postprocess
- * devices: client stub for DeviceCollection.update_persistent
- * tools: restore qvm-start --cdrom and similar options
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
- qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
- * tools/qvm-run: fix handling small data blocks
- * vm: add DispVMWrapper for calling a single service in new DispVM
- * tools: add qvm-run --dispvm option
- * doc: list known features in qvm-features manual page
- * app: add VMCollection.values()
- * tools/qvm-run: do not use os.set_blocking
- * tools/qvm-device: list attach options
- * doc: add default values to qvm-features man page
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
- qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
- * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
- agent
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
- qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
- * tools/qvm-backup-restore: fix default list of VMs to restore
- * storage: drop 'internal' volume property
- * tools/qvm-volume: fix default action handling
- * tests: qvm-backup-restore tool tests
- * tools/qvm-backup-restore: fix restoring only specific VMs
- * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
- * backup: move BackupRestore class and helpers to 'restore' submodule
- * tools: add qvm-backup tool
- * debian: update build depends
- * doc: update qvm-backup man page
- * backup/restore: improve error reporting
- * backup/restore: add option to ignore size limit
- * events: add variable Admin API method name
- * tools/qvm-shutdown: drop --force option, it isn't supported anymore
- * tools/qvm-shutdown: fix help message
- * tools/qvm-start-gui: add --force-stubdomain options
- * features: serialize True as '1'
- * tests: too much copy&paste
- * tools: qvm-service tool
- * doc: update manpage of qvm-service
- * qvm-ls: fix total VM size reporting
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
- qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * vm: make QubesVM objects hashable
- * events: simplify wait_for_domain_shutdown coroutine
- * tools: handle shutdown order in qvm-shutdown
- * tests/tools: add MockEventsReader
- * tests: qvm-shutdown --wait tests
- * Fix VM creation with default template
- * events: fix cleanup function in qrexec case
- * tests: improve test failure message
- [ Marta Marczykowska-Górecka ]
- * added helper function updates_vms_status
- [ Marek Marczykowski-Górecki ]
- * tools/qvm-run: fix handling copying stdin to the process
- * tests: mark qvm-run tests with "expected failure"
- * tools/qvm-run: fix handling EOF
- * Make pylint happy
- * Don't try to set 'created-by-' tag when cloning VM
- * backup: initial support for backup restore over Admin API
- * tests/backup: tests for backup-restore code
- * Exclude 'qubesadmin.backup' module from python2 install
- * devices,features: fix bool values handling
- * tests/backup: use smaller images
- * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
- * backup: add firewall and appmenus list handling
- * firewall: fix handling DstHost.prefixlen=0
- * tests: backup: add firewall.xml and appmenus checking
- * tools: add qvm-backup-restore
- * app: call admin.vm.volume.Import as root
- * backup: do not show full stacktrace to the user
- * backup: change 'hvm' property to 'virt_mode'
- * backup: use 'cat' instead of read-write loop in python
- * backup: improve error logging
- * tools/qvm-backup-restore: handle VMs selection, not only exclusion
- * Choose QubesLocal or QubesRemote based on /etc/qubes-release
- presence
- * Change 'hvm' property to 'virt_mode'
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
- qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
- *
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
- qubes-core-admin-client (4.0.0-1) unstable; urgency=low
- * Initial release
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200
|